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INTRODUCTION 

This User Guide is designed to serve as a brief overview to help you get started. There is also 
information available under the Help option in the various Contributor interface toolbar. If necessary 
you can access the Help by launching the Contributor interface from the System Tray and selecting Help-
>Help and Support. 

If you would like further instructions, please consult the Features list at 
http://support.colligo.com/Lists/Features/AllItems.aspx where you will find a complete list of features 
by product along with instructions for use. You will also find a number of screencasts on the support site 
that walk you through the main product features. The SharePoint support site can be synchronized with 
Colligo Contributor for anytime access, online or offline. Please follow the instructions on the home 
page at http://www.colligo.com/support/.  

Please send questions and feedback to support@colligo.com.  

  

http://support.colligo.com/Lists/Features/AllItems.aspx
http://www.colligo.com/resources/screencasts/
http://www.colligo.com/support/
mailto:support@colligo.com
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TECHNICAL REQUIREMENTS  

Systems Supported 

 Microsoft® Windows® 7 Home Premium; Professional or Ultimate 

 Microsoft® Windows® Vista Business; Enterprise or Ultimate 

 Microsoft® Windows® XP Home or Professional 

 Microsoft Office 2003 – 2010(Office 2003 SP2 or later for InfoPath forms) 

 Internet Explorer 6.0 or later 

 SharePoint Server 2010, MOSS 2007 and SPS 2003; SharePoint Foundation and WSS (2.0 or 3.0); 
SharePoint 2010 Online (Office365) and BPOS 

 Consumes roughly 20MB of disk space, not including content 

 If you are running a previous version, the new version can be installed over top of the old 
version without an uninstall. This also preserves all of the cached content.  

Application Prerequisites 

 Microsoft® .NET framework 3.5 Runtime 

Outlook Add-in Prerequisites 

 Compatible version of Outlook (Outlook 2010, 2007 or 2003) 

 Office 2003 or Office 2007 Primary Interop Assemblies (depending on which version of Office is 
installed) 

 Microsoft Visual Studio 2005 Tools for Office Second Edition (VSTO 2005 SE) Runtime 

 Microsoft Visual C++ 2008 SP1 Redistributable Package 
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INSTALLING COLLIGO CONTRIBUTOR 

Colligo provides both an .exe installer and an .msi installer for Contributor.  

There are different installer packages dependent on which version of Office you have installed: 

 For 32-bit Office, use the x86 installer 

 For 64-bit Office, use the x64 installer 

EXE Installer 

This installer package is an executable file with the following key features: 

 Supports interactive install only (does not support silent install) 

 Automatically installs software prerequisites (downloaded from www.colligo.com) 

 Not customizable 

Interactive EXE Install 

NOTE: Microsoft Outlook must be closed for the installation to be successful.  

1. Double-click the installation file.  
2. Prerequisites are downloaded and installed. 
3. Enter your license key. 

Colligo Contributor can be set to launch at Windows Start Up. This enables the background 
synchronization to start automatically.  

MSI Installer 

The MSI installer package has the following key features: 

 Supports silent and interactive installs 

 Does not install prerequisites - these must be downloaded and pre-installed 

 Customizable 

Interactive MSI Install 

NOTE: Microsoft Outlook must be closed for the installation to be successful. 

1. Ensure prerequisites are installed. 
2. Double-click the installation file.  
3. Enter your license key. 

Terminal Server Install 

For information on installing in a Terminal Server environment see the Colligo Contributor Terminal 
Server User Guide 

Concurrent Version Installations 

Colligo does not support side-by-side installations, running multiple versions or different versions of 
Contributor.  

Version Reversion/Downgrading 

It is not possible to revert to an earlier version of Contributor after upgrading as the database is often 
updated.  

  

http://www.colligo.com/_documents/Colligo_Contributor_Terminal_Server_User_Guide.pdf
http://www.colligo.com/_documents/Colligo_Contributor_Terminal_Server_User_Guide.pdf
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FILE MANAGER 

Adding a Site to Contributor 

It is possible to add a site to Contributor in a number of ways, including: 

 Use the Connect to Contributor option in Internet Explorer 

 File > New > Download Site menu option 

 Right-click the Site drop-down menu and select Download Site… 

Using the Connect to Contributor Option 

1. Navigate to a SharePoint site in Internet Explorer. 
2. Click the green Connect to Contributor icon on the toolbar. 

 

3. Contributor prompts you to enter your credentials for this site. You may use default windows 
credentials or enter other specified credentials. 

 

4. If the site you are connecting to is an Office365 site, a prompt for your Office365 credentials 
displays: 
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Contributor accesses the SharePoint web-services and requests a list of Lists and Libraries you have 
access to. Once Contributor has received the list, you are able to select which lists you want to 
synchronize. 

Synchronizing Lists 

You may choose to: 

 Synchronize all document libraries and lists 

 Synchronize specific lists (described below) 
Select the lists you wish to Synchronize by checking the box next to the list in the Select for 
Synchronization dialog. 

You may apply a filter to each list to restrict cached content. Available filters are: 

 All folders or specified folders; all subfolders will also be synchronized 

 A collection of Views; Contributor synchronizes all content selected in any View 

The Select Filters for Synchronization process is shown below: 

 

Contributor synchronizes the selected content. 
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Once Synchronization is complete you are ready to start working with the cached content. 

Editing Content 

1. Open a document by double-clicking on the item. 
2. Right-click on an item to: 

 Edit the properties (metadata) of the item 

 Open/Edit a document 

 Check Out, Check In, or Discard Check Out 

 Rename content 

 Delete content 
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Creating New Content 

New content can be created by selecting the New option. 

In SharePoint 2007, site content can be created based on content type templates. 

 

Using the File SaveAs Command 

The Colligo for SharePoint root location appears in Save As dialogs that use the standard Windows 
Explorer tree. Saving a file into the Contributor location creates a new file and a metadata prompt to 
request the content type and associated metadata data completes the creation process.  
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Uploading Existing Content 

Existing content can be added to Contributor by selecting the Upload option. Contributor prompts for 
metadata when the document is uploaded. 

 

Uploading Content with Drag-and-Drop 

Alternatively you can drag-and-drop content into Contributor from your desktop. Contributor accepts 
one or more files or complete folder structures for uploading. Contributor prompts for metadata when 
the items are uploaded. 
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Copying Existing Content 

Existing content, files, or folder structures can be copied between SharePoint document libraries or 
folders by either a drag-and-drop or copy-and-paste operation. Copy-and-paste can be accessed through 
standard Windows operations, such as right-click or Ctrl-C/Ctrl-V keyboard shortcuts.   

A new copy of the files or folders is created in the destination location and Contributor prompts for 
metadata. In cases where the metadata structure in the destination library is different from the source 
library, Contributor makes a best effort to match and retain existing metadata values. 

Sharing Content with Other Users 

Copying a SharePoint URL 

You can share content with other users by right-clicking on an item and selecting Copy SharePoint URL. 
The URLs for the selected items are copied to your clipboard and can be pasted into applications, files, 
or emails. 

Drag-and-Drop, Copy-and-Paste 

Alternatively, for users that do not have access to the SharePoint site, it is possible to drag-and-drop or 
copy-and-paste files or folder structures from the Contributor File Manager into a Windows folder, a file, 
or as an attachment to an email.  
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DEFAULT METADATA AND PROMPTING BEHAVIOR 

Contributor allows you to specify default values for metadata. Default values can be set at a document 
library, or subfolder level. The default values support both inheritance and propagation.  

Introducing the Metadata Dialog 

A sample of the Default Metadata dialog is displayed below. The following table explains the function of 
the dialog. 

 

List Selector Panel 

 

The List Selector allows you to change the List or Subfolder you wish to work with. 

NOTE: The List selector is only visible if the dialog is access through the File menu. 

Default Value 
Settings 

 

Name The Display Name of the SharePoint column 

Value The default value to be applied. 

Inherited From Indicates where Contributor receives this value from. The ‘Inherit 
From’ column may take the following values: 

 SharePoint Column definition 

 <not inherited> 

Parent Object Name. This may be the name of a document library of 
parent folder. 

Apply To Indicates whether the default value may be inherited by a subfolder. 
The Apply To folder may take the following values: 

 This Folder and subfolders 

 This Folder only 

Add, Edit and 
Remove 

These buttons allow you to work with the locally defined default values.  

Multiple items can be selected for removal using the Windows standard Ctrl and Shift 
selection modifiers. 

Inherit propagating 
values from parent 
items 

This folder will inherit propagating values from the parent item. Values specified with ‘This 
Folder and subfolders’ are propagating values and may be inherited. 

When un-checking the option Contributor provides the option to copy inherited values 
locally. 

 

 

 

1. List  Selector Panel 
2. Default Value Settings 
3. Add, Edit and Remove 
4. Inherit propagating values from 

parent items 
5. Clear locally-defined values on all 

child items 
6. Prompting Behavior 
 

5 

4 

3 

6 

2 1 
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Clear locally-defined 
values on all child 
items 

When settings are applied with this values checked, child-items are reset to inherit values; 
any user-specified default values on child-items are cleared. 

Prompting Behavior 

 

Modify the prompting behavior. The options are: 

 Always: The metadata prompt will be displayed when an item is added 

 Never: The metadata prompt will not be displayed when an item is added 

 According to application global settings: Prompting behavior is as defined in the 
View > Options dialog 

Child items that are configured for inheritance will inherit this setting. 

Accessing the Dialog 

File Menu 

The File menu may offer different options depending on the elements of Contributor deployed. The 
Contributor Control Panel interface may be accessed by double-clicking the Contributor icon in the 
system tray.  

   

Control panel 

* When accessed through the File menu, the Default Metadata dialog includes the List Selector 
Panel. 
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Context Menus 

You can access the default metadata dialog by right-clicking on a list in the folder area or on a folder in 
the cached view.  

                       

* When accessed through the context-sensitive menus, the Default Metadata dialog does not 
include the List Selector Panel; the dialog applies values to the selected list or subfolder. 

SYNCHRONIZING CONTENT 

Contributor offers different user-configurable synchronization processes to ensure data is kept 
synchronized with SharePoint. Synchronization runs silently in the background, allowing you to continue 
working with your documents. 

Automatic Synchronization Processes 

 

Synchronize on startup: Contributor synchronizes 
cached content when it starts 

Synchronize when list is viewed: When you 
navigate to a list the content is synchronized 

Synchronized when list is modified: Modifications 
include changes to the document or metadata 

Enable background synchronization: Contributor 
synchronizes content periodically. The default 
sync-interval is 30 minutes. 
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Manual Synchronization Processes 

 Synchronize Multiple Sites: Allows selection of specific sites to synchronize 

 Synchronize All: Synchronizes all sites defined in Contributor 

 Synchronize Pending Changes: Synchronizes lists containing changed content  

 

Full Synchronization 

Several of the synchronization processes allow you to specify ‘Full Synchronization”. When Contributor 
performs a full synchronization additional information is downloaded, this includes definitions for Sites, 
Lists, Views and Content-Types, etc, plus other site-content that may not be retrieved during other 
standard sync processes.  

Pending Changes Synchronization 

You may review content that has changed since the last synchronization by accessing the View > 
Pending Changes window. For each item with a pending change you can choose to discard the changes. 
Discarded changes are reverted upon the next synchronization. 
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CONFIGURATION 

Contributor provides easy access to the common configuration options: 

 

For details regarding the Synchronization options please check the Synchronizing Content section. 

Prompt for Properties when Adding Documents 

By default Contributor prompt for metadata when content is added. You can disable the prompt. If the 

prompt is disabled, content is uploaded to SharePoint with default metadata. 

Storage Location 

You are able to move the Contributor cache to another location. 

Automatically Downloading Lists to Resolve Site Column Values 

Contributor ensures that data for Lookup columns is also synchronized. 

file:///C:/Users/User/Desktop/_Work%20Files/Colligo/Contributor/Docs%20for%20editing/Colligo%20Contributor%20v4.3%20FileMgr%20-%20User%20Guide.docx%23_Synchronizing_Content

