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Introduction 
This document provides guidance for your deployment of Colligo Contributor. 

User documentation is provided on the Colligo Contributor support website: 
http://www.colligo.com/support/ including a series of short screencasts introducing the product 
http://www.colligo.com/resources/screencasts/ 

For any further technical details please contact Colligo Technical Support at support@colligo.com, or for 
sales related question please contact sales@colligo.com. 

Target Audience 
 IT Administrator 

 Technical Evaluator 

 Deployment Manager 

Overview 
Colligo Contributor is an easy-to-deploy .NET client-only application; no server modifications are 
required. The installer package is just 5 MB in size. Installed, it consumes roughly 11 MB of disk space, 
not including content. Colligo Contributor for SharePoint is IT-department friendly. It supports 
customized installations and can be deployed using your choice of deployment tools.  

Colligo Contributor supports SharePoint sites based on the 2010, 2007 and 2003 releases, and includes 
an add-in to integrate with Outlook 2010, 2007 and 2003. 

Editions 
Colligo issues a number of SKUs of the product. Along with the standard full product, a read-only version 
and an online-only version with no caching are available. Switching between editions is simply a case of 
registering a new license key. 

Colligo Contributor Pro 
Easily file, tag, view, and share documents, emails, and attachments in SharePoint when working offline. 
Colligo Contributor Pro includes Colligo Contributor Add-in for Outlook, Colligo Contributor File 
Manager, and Colligo Contributor Client in a single, value-priced bundle. 

Colligo Contributor Add-in for Outlook 
Drive SharePoint adoption for email and content management with easy access directly from Outlook. 
Choose Send & File, or simply drag-and-drop emails and attachments into document libraries and 
folders, instantly capturing critical metadata. The built-in Attachment Manager easily stores email 
attachments in SharePoint, replacing them with links. 

Colligo Contributor File Manager 
Increase SharePoint adoption by seamlessly linking folders on your file system with SharePoint 
document libraries. Local folders become “SharePoint aware”, providing easy access to SharePoint 
features such as metadata, content types, and document templates. Folders can also be easily accessed 
from any application that uses the standard Windows File Open/Save dialog. SharePoint files can be 
added and edited using familiar desktop operations. 

Colligo Contributor Client 
Extend the power of SharePoint to mobile and remote workers. Instantly and securely access, modify, 
and create SharePoint documents, list items, and metadata while offline. Sync changes to libraries and 

http://www.colligo.com/support
http://www.colligo.com/resources/screencasts/
mailto:support@colligo.com
mailto:sales@colligo.com
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lists automatically when connected. Keep team members productive, regardless of network latency or 
unavailability, in the field or on the road. 

Localization 
Colligo Contributor is available in English, French, German, Spanish (Castilian) and Spanish (Mexican) 
languages. Colligo Contributor localizes to the base language of the running machine, defaulting to 
English. 

System Requirements 

Software Requirements 
Colligo Contributor requires the following software: 

 Windows 8 

 Windows 7 

 Windows XP Professional 

 Windows Vista 

Client Software Requirements 
Colligo Contributor has the following client software requirements: 

 Microsoft .NET framework 3.5 Runtime 

 Microsoft .NET framework 4.0. Runtime 

 Integration with Microsoft Office requires Office 2003 or later 

 Microsoft Office 2003 SP2, 2007, 2010, 2013 

 Microsoft Office Primary Interop Assemblies (PIAs). Different versions of Office have different PIAs. 
PIA’s must be deployed corresponding with the version of Office installed 

 Microsoft Visual Studio 2005 Tools for Office Second Edition (VSTO 2005 SE) Runtime  

 Microsoft Visual C++ 2010 SP1 Redistributable Package 

Server Software Requirements 
Colligo Contributor requires at least one of the following: 

 Microsoft SharePoint Server 2010, MOSS 2007, or SharePoint Portal Server (SPS) 2003 

 SharePoint Foundation Microsoft Windows SharePoint Services (WSS) 3.0, or 2.0 

 SharePoint 2010 Online (Office365) 

 SharePoint 2013  
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Installing Colligo Contributor 
Colligo provides both an .exe installer and an .msi installer for Colligo Contributor.  

There are different installer packages dependent on which Operating System you have: 

 For a 32-bit Operating System, use the x86 installer 

 For a 64-bit Operating System, use the x64 installer 

.exe Installer 
This installer package is an executable file with the following key features: 

 Supports interactive install only (does not support silent install) 

 Automatically installs software prerequisites (downloaded from www.colligo.com) 

 Not customizable 

Interactive .exe Install 
NOTE: Microsoft Outlook must be closed for the installation to be successful.  

1. Double-click the installation file.  
2. Prerequisites are downloaded and installed. 
3. Enter your license key. 

Colligo Contributor can be set to launch at Windows Start Up. This enables the background 
synchronization to start automatically.  

MSI Installer 
The MSI installer package has the following key features: 

 Supports silent and interactive installs 

 Does not install prerequisites - these must be downloaded and pre-installed 

 Customizable 

Interactive MSI Install 
NOTE: Microsoft Outlook must be closed for the installation to be successful. 

1. Ensure prerequisites are installed. 
2. Double-click the installation file.  
3. Enter your license key. 

Silent Install or Uninstall 
You can use the msiexec utility to install or uninstall silently. 

To perform a silent install, use the following command line: 
msiexec /i <Installer.msi> /qn 

For example:  
msiexec /i ColligoContributor.msi /qn 

To perform a silent uninstall, use the following command line: 
msiexec /x <Installer.msi> /qn 

You can install a customized version of Colligo Contributor using the msi installer. When using a batch 
file to install a customized msi package, it is important to ensure the prerequisites are installed before 
attempting to install Colligo Contributor. An example batch file is listed below: 

http://vs-sp2010/PM/Shared%20Documents/Contributor/User%20Documentation/www.colligo.com
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msiexec /i \\server\ContributorInstall\PreReq\O2007PIA.MSI /qn 

\\server\ContributorInstall\PreReq\vstor.exe /q 

msiexec /i \\server\ContributorInstall\CustomColligoContributor.msi /qn 

Terminal Server Installation Considerations 
There are a number of specific issues which must be considered when installing Colligo Contributor in a 
terminal server environment. Each of these requires specific installation and configuration affects the 
product operation. 

Activation and Licensing 
Colligo Contributor is normally licensed on a per user / per machine basis and the activation system is 
used to enable and authorize client installation. Each Colligo Contributor client performs an activation 
request to the Colligo Activation servers to gain the necessary authorization for execution. The results of 
this activation are recorded in a special file that is stored in the installation area of Colligo Contributor. 

In a terminal server environment, where the users profile and storage may be located on network 
storage or may be created on demand, this activation file may not be maintained between sessions 
leading to unnecessary and repeated activation requests. 

There is special licensing and license keys available for use with a terminal server environment which 
eliminates this activation request traffic. For further information contact Colligo Sales. 

Cache Location 
Colligo Contributor uses a local database and cache to hold SharePoint configuration and content. 
Normally this is stored in the local PC file system but in a terminal server environment this must be 
moved to a network accessible location. 

When installing using a customized MSI the field to specify the cache location is STORAGE_ROOT 

The registry setting to specify the cache location is General\Storage_Root. 

The cache should be on a commonly accessible network location which is available to all of the servers 
which a user could login and receive a terminal session. 

Outlook Folder Storage 
Colligo Contributor’s default behavior is to create a set of Outlook storage folders based on the local 
machine name. This allows the user to have multiple machines and multiple instances of Colligo which 
are using different caches and configurations. Because Microsoft Exchange and Outlook reflect the 
Exchange folders to each Outlook client the various Colligo for SharePoint folders each are displayed in 
the users Mailbox and Colligo distinguishes between them by appending the machine name on which 
the cache and configuration is locally resident. 

In a terminal server environment where multiple machines (servers) are used but the user has only one 
networked cache location and configuration this behavior should be suppressed and a single Colligo for 
SharePoint root folder displayed and used by all instances of Colligo. 

When installing using a customized MSI, the field to suppress the machine name is 
DISABLE_OUTLOOK_MACHINE_ID. 

The registry setting to suppress the machine name, Outlook\DisableMachineId, should be set to 1 
(Enabled). 

Multi-Session Behaviors 
Colligo Contributor uses a database and a cache to store the SharePoint configuration and content. 
Having multiple sessions simultaneously access this shared resource can lead to conflicts, unexpected 

mailto:sales@colligo.com?subject=Terminal%20Server%20Licensing%20Information%20Request
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database results and general user confusion. To help control this, Colligo Contributor has a mechanism 
to suppress operations at all sessions except at the session where the user is currently located.  

When installing using a customized MSI the field to support single session operation is USE_SYNC_LOCK. 

The registry setting field to support single session operation is General\UseSyncLock should be set to 1 
(Enabled). 

Configuration Options 
Colligo Contributor saves settings in the registry. Many settings can be configured post-install by pushing 
out settings to the registry. Colligo Contributor offers administrators the ability to configure a number of 
settings at install or post-install time. A detailed list of settings is maintained on the Colligo website at 
http://www.colligo.com/support/settings/contributor/  

Editing the MSI 
To edit the MSI installer package you need an MSI database editor. Colligo recommends the Orca 
database editor. Orca is a Microsoft utility for modifying and validating Windows Installer packages. It is 
intended to allow setup authors and administrators to manipulate databases compatible with the 
Windows Installer Service. This utility is a part of the Windows Installer SDK download, along with other 
MSI related tools.  

An introduction to Orca can be found on the Microsoft site: 
http://support.microsoft.com/kb/255905/EN-US/ 

Installing the Orca MSI editor 
Instead of downloading the entire Windows Installer SDK, you can download Orca from Colligo’s web 
site: http://www.colligo.com/support/kb/orca-msi-editor/  

Using Orca to Edit the MSI 
Once you have installed Orca, you can start editing the Colligo Contributor.msi file. Colligo recommends 
copying the MSI file and working on the copy (since Save As in Orca does not save the entire MSI 
package. 

Editing an MSI file: 
1. Open the MSI file in Orca. 
2. Navigate to the Property table in the Tables list. 

 

http://www.colligo.com/support/settings/contributor/
http://support.microsoft.com/kb/255905/EN-US/
http://www.colligo.com/support/kb/orca-msi-editor/
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3. From the Tables menu, select Add Row.  
The Add Row dialog displays: 

 

4. Enter the Property name and Value.  
5. Click OK.  

The new property displays in the Property Table. 

NOTE: The property names are case sensitive. 

NOTE: When editing an MSI database using Orca, there are extra steps required if you perform a 
Save As…. As a best practice, it is advisable to edit an MSI database and Save the file being edited. 

Editing the Registry 
Registry settings may be stored under HKEY_LOCAL_MACHINE or HKEY_CURRENT_USER. Values under 
HKEY_LOCAL_MACHINE take precedence. Values are stored in: 

 HKEY_LOCAL_MACHINE\Software\ColligoOfflineClient 

 HKEY_LOCAL_MACHINE\Software\Wow6432Node\ColligoOfflineClient (x64 machines) 

 HKEY_CURRENT_USER\Software\ColligoOfflineClient 

Registry keys must be in the form of Key/String Value. To add a string value to a registry key: 
1. Open the Registry Editor.  
2. Navigate to the Key you want to add a new String Value to. For example, if the key is 

Outlook/DisableAddInStartupSync, Outlook is the key and DisableAddInStartupSync is the string 
value within the Outlook Key.  

NOTE: If the key doesn’t exist, you can create it by right clicking on the parent key and select New 
Key from the contextual menu.  

3. Right-click on the right side and select New > String Value from the contextual menu:  
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A new String Value appears in the Name list.  
4. Enter the name of the String Value; in this example, it would be DisableAddInStartupSync.  

To edit the name of the String Value, right click it and select Rename from the contextual menu: 

 

5. Press Enter or right-click and select Modify from the contextual menu to display the Edit String 
dialog: 

 

6. Enter the Value data and click OK.  
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Registry Configuration Editor 
A Registry Configuration Editor is available with Colligo Contributor to easily change registry settings, 
create registry files for deployment, and to provide explanation and information on registry settings. 
This editor, described in the Configuration Editor User Guide is available in the Colligo Contributor 
Programs area in the Start toolbar. 

Colligo Contributor saves settings in the Registry. Per-user settings are saved in the following key: 
HKEY_CURRENT_USER\SOFTWARE\ColligoOfflineClient 

All the settings keys can also be accessed from the equivalent location in the Local Machine Hive: 
HKEY_LOCAL_MACHINE\SOFTWARE\ColligoOfflineClient 

 Settings saved under the Local Machine hive are not editable by a standard user 

 Settings in the Local Machine will take priority over settings in the Current User Hive 

 Settings that are displayed in the Configuration Options and have a value specified in the Local 
Machine Hive are greyed-out (disabled) in the Configuration Options panel 

Example: To disable a user’s ability to edit the Storage Location: 

Save the General\StorageRoot registry setting into the HKEY_LOCAL_MACHINE hive: 

Registry key settings file (storage.reg): 

Windows Registry Editor Version 5.00 

[HKEY_LOCAL_MACHINE\SOFTWARE\ColligoOfflineClient\General] 

"StorageRoot"="%UserProfile%\\Local Settings\\Application Data\\ > 

ColligoOfflineClient\\EncryptedStorage5" 

Command: 
RegEdit /s storage.reg 

  

http://www.colligo.com/support/media/document/ColligoContributor4.3Configuration-Editor-UserGuide.pdf
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Communications 
Colligo Contributor communicates with SharePoint through the web services, the details of which are 
available on MSDN at: http://msdn2.microsoft.com/en-us/library/aa979690.aspx.  

These web services calls are transmitted over HTTP (or HTTPS) using TCP. Colligo Contributor also uses 
FrontPage RPC methods to communicate with the SharePoint server. FrontPage RPCs are also 
transmitted over HTTP(S) and TCP.  

Details of the FrontPage RPC protocols are available on MSDN at: http://msdn2.microsoft.com/en-
us/library/ms954084.aspx. 

The services described above are installed and enabled on SharePoint by default. Because they are 
layered on top of TCP/HTTP, communication works over most WAN/VPN and/or wireless connections, 
as well as a standard LAN. 

Web Proxy Configuration 
Colligo Contributor can be configured to use a web proxy. Proxy options are either:  

 Direct connection (No Proxy) 

 IE’s default proxy 

 Other proxy 
For more information about configuring this setting, see http://www.colligo.com/support/settings/web-
proxy-settings/ 

The other proxy is defined in the CFS.exe.config file according to the specifications listed on msdn here: 
http://msdn2.microsoft.com/en-us/library/kd3cf2ex(vs.80).aspx 

SharePoint Security and Privileges 
By using SharePoint’s web services to access SharePoint data, Colligo Contributor respects all privileges 
defined on the site. A user needs at least read access to an item in order to cache it. Colligo Contributor 
supports most standard sign-on processes supported by SharePoint, including support for default 
credentials and other specified credentials. Passwords are stored in a secure manner using the Windows 
Cryptographic API.  

The following standard Windows IIS authentication types are supported:  

 Basic 

 Digest 

 Kerberos (Integrated Windows) 

 NTLM (Integrated Windows) 

SharePoint by default does not provide web service permissions to anonymous users, so this permission 
level cannot be used for taking sites offline. Client certificates, ASP.NET forms-based authentication, and 
single-sign-on (SSO) based on Active Directory Federation Services (ADFS) or similar identity 
management systems are not currently supported. 

Cache location and Encryption 
Colligo Contributor caches SharePoint content on the local machine. The default cache location is in the 
users local profile area located at the following location in Windows XP: 
%UserProfile%\Local Settings\Application Data\ColligoOfflineClient\Storage5 

http://msdn2.microsoft.com/en-us/library/aa979690.aspx
http://msdn2.microsoft.com/en-us/library/ms954084.aspx
http://msdn2.microsoft.com/en-us/library/ms954084.aspx
http://www.colligo.com/support/settings/web-proxy-settings/
http://www.colligo.com/support/settings/web-proxy-settings/
http://msdn2.microsoft.com/en-us/library/kd3cf2ex(vs.80).aspx
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You can change the location to any other valid path including: the local file-store; network location; or 
other (for example, USB drive). For performance and connectivity reasons the local file-system is the 
preferred location for the cache. 

Colligo Contributor can be configured to secure data using the Windows Encrypting File System (EFS); a 
good introduction to Windows EFS can be found on Wikipedia: 
http://en.wikipedia.org/wiki/Encrypting_File_System. EFS can be configured to be compliant with the 
Federal Information Processing Standard (FIPS 140-1 and FIPS 140-2).  

Microsoft TechNet published an evaluation of EFS for FIPS compliance here: 
http://www.microsoft.com/technet/archive/security/topics/issues/fipseval.mspx. 

Server-side events 
SharePoint may have server-side event-handlers defined. Typically event handlers may be added to the 
ItemAdding or ItemAdded events. These events are triggered when Colligo Contributor performs 
content operations. The event-handlers may operate synchronously of asynchronously (typically 
ItemAdding would be synchronous, ItemAdded would be asynchronous). Event handlers that perform 
asynchronously and change the content must be sure to increment the internal item version to ensure 
Colligo Contributor is notified of the content updates. 

Workflow 
Workflows are typically started or progressed by content changes. For example the Get Approval 
workflow starts when a document is changed and requires approval. Colligo Contributor works with 
workflow such that content changes will initialize workflows on the server. There is no support for local 
workflows on the client. 

Configuring SharePoint for Email Metadata 
Colligo provides a sample list template file that can be used to create a sample testing document library. 
Download the template from the Colligo support site, install it to the List template gallery, and use it to 
create a new document library in your site.  

Downloading the List Template 
You can download the list template from the following location: 
http://www.colligo.com/support/kb/default-column-names-for-email-metadata-mapping/ 

Download the attachment CfsEmailLibrary2010.zip.  

The zip file contains a site template named CfsEmailLibrary2010.stp. 

Installing the Sample List Template  
1. Extract the list templates to the preferred location. 
2. Navigate to the site collection you want to add the list template to.  
3. In your SharePoint site, navigate to Site Actions -> Site Settings. 
4. On the Site Settings screen, in the Galleries section, select List Templates: 

http://en.wikipedia.org/wiki/Encrypting_File_System
http://www.microsoft.com/technet/archive/security/topics/issues/fipseval.mspx
http://www.colligo.com/support/kb/default-column-names-for-email-metadata-mapping/
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5. In the List Template Gallery, in the Library Tools > Documents ribbon, click Upload Document:  

 

The Upload Document dialog displays. 
6. Browse to the list template file (CfsEmailLibrary2010.stp) and click OK.  

The List Template Gallery dialog displays: 

 

7. Enter the following information: 
a. Name: enter a name for the template gallery 
b. Title: enter a title that reflects the use of the template gallery 
c. Description: enter a description for the template gallery 

8. Click Save.  
The new list template displays in the List Template Gallery. 
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Creating a Site 
After you have installed the list template, you can create a new library based on the template.  

1. Navigate to the site collection you want to add the list template to.  
2. Select Site Actions > More Options. 

The Create dialog displays. 

 

3. Select the name of the list template you added. 

NOTE: the name of the list template displays with the title you entered in step 7.b of Installing the 
Sample List Template. 

4. In the right pane, enter a name for the library, and click Create.  
5. Under the Library Tools > Documents ribbon, click the New Document drop-down arrow. The new 

Document Library displays as an option: 

 

Manually Creating Content Types 
Colligo Contributor fully supports Content Types, and when working with Email documents Colligo 
recommends you create a content type for your email documents.  

Enabling Metadata Extraction 
To enable metadata extraction to a document library, you need to create a document library with 
columns that are defined to have metadata extracted into them. Columns can be created either directly, 
or by adding an existing content type to the library. 

Colligo Contributor extracts the following metadata properties from emails:  
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Email Metadata Default Column Name Type 

Attachment Attachment Yes/No 

Bcc Bcc Text 

Bcc-Address Bcc-Address Text 

Bcc-Type Bcc-Type Text 

Categories Categories Text 

Cc Cc Text 

Cc-Address Cc-Address Text 

Cc-Type Cc-Type Text 

Conversation Conversation Text 

From From Text 

From-Address From-Address Text 

From-Type From-Type Text 

Importance Importance Number 

Received Received Date/Time 

Received-UTC Received-UTC Date/Time 

Sensitivity Sensitivity Number 

Sent Sent Date/Time 

Sent-UTC Sent-UTC Date/Time 

Subject Subject Text 

To To Text 

To-Address To-Address Text 

To-Type To-Type Text 

NOTE: Text fields can be Single Line of Text, or, Multiple Line of Text.  

The Default Column Name refers to the display name of the SharePoint column  

Metadata can be extracted into alternatively named columns. To extract metadata into non-default 
column names, see Changing Column Mappings. 

Adding a New Content Type to a Library  
When creating an email content type, suitable SharePoint permissions are required. Typically, the email 
content type is created in the top level site within a site collection, allowing inheritance and 
customization in sub-sites.  

1. In your document library, select Site Actions > Site Settings. 
2. In the Galleries section, select Site content types:  
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3. In the Site Content Types page, click Create: 
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The New Site Content Type screen displays: 

 

4. Enter the following information: 
a. Name and Description 

i. Name: enter a name for the content type 
ii. Description: enter a description for the content type 

iii. Parent Content Type: from the first drop-down list, select the parent content type 
group; in the second drop-down list, select the parent content type.  

b. Group: choose if the content type is put into either: 
i. Existing group: choose an existing content group from the drop-down menu 

ii. New group: enter a name for a new content group 
5. Click OK.  

The content type is added.  
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Configuring Content Types 
After adding a content type, you can add existing site columns as well as create new site columns.  

1. On the new content type page, click either: 
a. Add from existing site columns 
b. Add from new site column 

 

Add Columns to a Content Type: 

 

2. Enter the following information: 
a. Select Columns: choose a group from the Select Columns from drop-down menu 
b. Update List and Site Content Types: choose if you want to update all content types 

inheriting from this type 
3. Click OK to display the New Site Column screen: 
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4. Enter the following information: 
a. Name and Type 

i. Column name: enter the column name 
ii. Choose a type of information contained in the column 

b. Group: choose if the column will belong to an existing group or a new one 
c. Additional Column Settings 

i. Description: enter a description for the column 
ii. Require that this column contains information: choose Yes if you require this 

column to be a mandatory field the user must fill out 
iii. Maximum number of characters: enter the maximum number of characters you 

want to have in this column 
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iv. Default Value: choose Text or Calculated Value 
d. Update List and Site Content Types: choose if you want to update all content types 

inheriting from this type 

After adding the columns to the Email Content Type you may choose to re-order the columns and/or 
make the columns hidden.  

Hiding Columns 
If you choose to make a column Hidden, the column is not displayed in the properties page of 
SharePoint, or Colligo Contributor’s default metadata editor dialog box.  

However, Colligo Contributor still extracts metadata into any hidden columns, and they can still be 
displayed in views, or used for filters. 

Adding a New Content Type to Library 
1. In your document library, go to Library Tools > Library ribbon and click the Library Settings icon.  
2. In the General Settings section, click the Advanced settings link: 

 

3. In the Advanced Settings screen, ensure the Allow management of content types option is set to 
Yes: 

 

4. Click OK to save the changes and return to the Library Settings screen. 
5. On the Document Library Settings screen, scroll down to the Content Types section: 
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6.  Click the Add from existing site content types link. 
7. In the Add Content Types screen, select a content type from the Available Site Content Types list, 

and click Add:  

 

8. Click OK to return to the Document Library Settings screen.  
The new content type displays in the Content Types section:  
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Creating a Library Without Content Types 
If you do not wish to use content types in your SharePoint library, you can add columns directly to the 
library to enable email metadata mapping. See Enabling Metadata Extraction for the metadata fields 
and default column names. 

1. In your document library, go to Library Tools > Library ribbon and click the Library Settings icon.  
2. In the Document Library Settings screen, scroll down to the Columns section and click Create 

Column: 

 

The Create Column screen displays: 

 

3. Enter the following information: 
a. Name and Type 

i. Column name: enter the column name 
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ii. Choose a type of information contained in the column 
b. Additional Column Settings 

i. Description: enter a description for the column 
ii. Require that this column contains information: choose Yes if you require this 

column to be a mandatory field the user must fill out 
iii. Enforce unique values: choose Yes if you want this column to have a unique value 
iv. Maximum number of characters: enter the maximum number of characters you 

want to have in this column 
v. Default Value: choose Text or Calculated Value 

vi. Add to default view: check this box if you want this column to display in the default 
view 

4. Click OK. 
The new column displays in the Columns section in your Document Library Settings list.  

Creating An Email View 
After you have defined your content type and added it to your library, it is recommended that you 
create an email view.  

1. In your document library, go to Library Tools > Library ribbon and click the Create View icon: 

 

The Create View screen displays: 

 

2. Click the Standard View link.  
The configuration options for the standard view display:  
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3. Enter the Name and Audience for your view. 
4. Click OK. You can now select this view from your Current View list in your Library ribbon: 

 

Validating Metadata Extraction 
To validate that your metadata is being extracted correctly, drag-and-drop an email into a Colligo for 
SharePoint Folder, and check that the correct metadata is being displayed and extracted: 
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Changing Column Mappings 
By default, the required SharePoint column display name matches the Outlook message field name 
shown in the table in Manually Creating Content Types. 

The email configuration file allows you to override the default mapping of the Outlook message field 
name to the SharePoint column display name.  

Name the file EmailConfig.xml and store it in the following location: <%UserProfile%>\Application 
Data\Local\Colligo Offline Client\Config\Email 

NOTE: the Colligo folder must be manually created. 

To adjust the SharePoint metadata column name for a particular Outlook message field, the SPColumn 
attribute of the appropriate Mapping element is changed. It is also possible to specify multiple mappings 
for the same message field. That is, the same field can be mapped to multiple SharePoint metadata 
columns. 

The format of the EmailConfig.xml file is shown below: 
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Centrally Configuring Content 
The Colligo for SharePoint Site Config File allows IT administrators to define a minimal set of sites, lists, 
libraries, and folders to be synchronized to a user’s computer. 

To generate a site config file, you need to first set up your Contributor workspace as preferred. 
Download your desired sites, and select the entire site or the desired lists and libraries for 
synchronization. You can also select individual folders or views for synchronization (rather than 
synchronizing an entire document library). All these settings are specified using the standard 
Contributor user interface. 

Once the synchronization settings are set up as desired, export the site config file using the File > Export 
Site Configuration File menu option within Contributor. The only file name requirement is that it must 
have a .xml extension. 

Outlook Folders 
Contributor Version 4.0 and later applications support creating folders in Outlook based on the site 
config file. To enable automatic Outlook folder creation, you must edit a Site Config file to include an 
<Outlook> node (see Defining Outlook Folders for details). 

Reading the Site Config File 
By default, Contributor synchronizes all sites on startup, and periodically every 30 minutes thereafter. 
You can configure the timing of these background synchronizations.  

Prior to each background sync, Contributor searches for site config files in the specified locations. All 
sites, lists, libraries, and folders specified in the site config files that are found are downloaded and 
synchronized as part of the background sync. 

If a user deletes a site, or deselects a list, library, or folder that is included in a site config file, the 
content is re-enabled for synchronization at the time of the next background sync. 

Site Config File Location 
To apply the site config settings on a particular user’s machine, the file must be copied to one of the 
following locations: 

 <%UserProfile%>\Application Data\ColligoOfflineClient\Config\Sites 

 <%UserProfile%>\Local Settings\Application Data\ColligoOfflineClient\Config\Sites 

 <%AllUsersProfile%>\Application Data\ColligoOfflineClient\Config\Sites 

Defining Outlook Folders 
To enable automatic Outlook folder creation, you must edit a Site Config file to include an <Outlook> 
node. Colligo recommends that you validate the customized Site Config file with the XML Schema File. 
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Node Format 
Each site defined in the Site Config File may contain zero or one <Outlook> nodes. The <Outlook> node 
may contain one or more <Folder> nodes. The <Folder> node provides details to Contributor to create 
the folder. A sample <Outlook> node is shown below: 

 

 

 

 

 

 

 

 

 

<Folder Node> Children 

Name Required Values Description 

ListID Yes Any valid GUID SharePoint’s ListID for the specified list 

Name Yes String Name of folder to create in Outlook 

ParentName No String If specified, Contributor creates a parent folder for 
this list 

Offline No true | false true: Contributor displays the Contributor Add‐In 
offline view 
false: Contributor sets the home page to a specified 
url 

OnlineUrl No Any valid url If <Offline> is false the folder‐home page is set to this 
url (ignored if <Offline> is true) 

Errors 
If the format of a site config file is invalid, an error message is logged each time the file is read. The error 
message is logged to the Contributor log file, found under the Help > Open Log File Folder menu option. 

NOTE: XML is a case‐sensitive language. Ensure any manually created nodes use the correct case. 

If the user’s default credentials are not sufficient to gain access to a site contained in the site config file, 
an access error displays in the Errors and Conflicts pane. When users double‐click on this error, they are 
given the option to change their credentials for the site. On the next background sync cycle, Contributor 
attempts to download the site using the new credentials. 

Uninstalling Colligo Contributor  
To uninstall, Colligo Contributor, complete the following steps: 

1) In your Control Panel, choose Uninstall a Program from the Programs group. 
2) Select Colligo Contributor in the program list and click Uninstall. 

<Outlook> 

       <Folder> 

<ListID>{2B8A5A19-E4C9-4FBB-A941-A2AC14BB69B4}</ListID> 

<Name> Documents (Offline)</Name> 

<ParentName>Project 44-12</ParentName> 

<Offline>true</Offline> 

        </Folder> 

        <Folder> 

<ListID>{2B8A5A19-E4C9-4FBB-A941-A2AC14BB69B4}</ListID> 

<Name>Documents (Online)</Name> 

<ParentName>Project 44-12</ParentName> 

<Offline>false</Offline> 

<OnlineUrl>http://server/Documents</OnlineUrl> 

        </Folder> 

</Outlook> 


