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CONTRIBUTOR™
File Manager

USER GUIDE

Introduction

This User Guide is designed to serve as a brief overview to help you get started. There is also information available under the Help
option in the various Contributor interface toolbar. If necessary you can access the Help by launching the Contributor interface from
the System Tray and selecting Help->Help and Support.

If you would like further instructions, please consult the Features list at http://support.colligo.com/Lists/Features/Allltems.aspx -
where you will find a complete list of features by product along with instructions for use. You will also find a number of screencasts
on the support site that walk you through the main product features. The SharePoint support site can be synchronized with Colligo
Contributor for anytime access, online or offline. Please follow the instructions on the home page at http://support.colligo.com/.

We hope you enjoy using the product, and please don’t hesitate to send us questions or provide feedback at support@colligo.com.
Thank You.
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Installing Colligo Contributor
Systems Supported

e  Microsoft Windows Vista: Business; Enterprise; Ultimate. (incl. SP1)

e Microsoft Windows XP Home or Professional

e Microsoft Windows' 2000 Service Pack 2 or greater

e Microsoft Office 2000 — 2007 (Office 2003 SP2 or later for InfoPath forms)

e Internet Explorer 6.0 or later

. WSS (2.0 or 3.0) and SPS 2003 and MOSS 2007

e  Consumes roughly 20MB of disk space, not including content

e If you have a previous version installed, the new version can be installed “over top” of the old version without needing to
uninstall. This will also preserve all of the cached content.

Application Prerequisites
e  .NET Framework 2.0
For XP or 2000, please ensure the .NET Framework 2.0 is installed first (included with Vista). You can check in the Control
Panel > Add/Remove Program.
e  .NET Framework 3.0
Required to support embedding and extraction of metadata from Office 2007 documents.

Outlook Add-in Prerequisites
e  Compatible version of Outlook (Outlook 2003 or Outlook 2007)
e Office 2003 or Office 2007 Primary Interop Assemblies (depending on which version of Office is installed)
e Microsoft Visual Studio 2005 Tools for Office Second Edition (VSTO 2005 SE) Runtime

Interactive EXE Install

Download the Colligo Contributor EXE installation file to your local computer.

Double-click on the installation file to install Colligo Contributor.

Prerequisites are downloaded and installed.

Enter your license key.

Colligo Contributor can be set to launch at Windows Start Up. This will enable the background synchronization to start
automatically.

Unattended MSI Install

1. Install the required prerequisites.

vk wh e

2. Download the Colligo Contributor MSl installation file to your local computer.
3. Double-click on the installation file to install Colligo Contributor.
4. Enter your license key.
5. Colligo Contributor can be set to launch at Windows Start Up. This will enable the background synchronization to start
automatically.
Notes

e Concurrent version installations
Colligo does *not* support side-by-side installations of different versions of Contributor.
ie: itis *not* possible to run multiple versions of Contributor concurrently

e  Version reversion/downgrading
It is ¥*not* possible to revert to an earlier version of Contributor after upgrading. When installing an update to Contributor,
the database is often updated.

e Microsoft’ Windows 2000
Microsoft” Office’ 2007 is *not* supported on Microsoft” Windows 2000. Contributor does *not* support metadata
embedding and extraction from Office’ 2007 documents on Windows 2000 systems.

More detail installation details are available on the support site:
http://support.colligo.com/Lists/Knowledqge%20Base/DispForm.aspx?ID=16
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The File Manager
Adding a Site to Contributor

It is possible to add a site to Contributor in a number of other ways, including:
e Use the “Connect to Contributor” option in Internet Explorer
e  File->New-> Download Site menu option
e  Right Click the site drop-down menu and select “Download Site...”

The simplest approach is using the “Connect to Contributor” option. This process is described below.

Step 1: IE Toolbar button “Connect to Contributor”

Navigate to a SharePoint site in Internet Explorer
Click the green “Connect to Contributor” icon on the toolbar
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Step 2: Enter your credentials

Contributor will prompt you to enter your credentials for this site. You may use default windows credentials or enter other specified
credentials.
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Contributor will access the SharePoint web-services and request a list of Lists and Libraries you have access to.
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Step 3: Choose the lists to sync

Once Contributor has received the list of Lists you are able to select which Lists you which to synchronize.
You may choose to:
e Synchronize all document libraries and lists.
e Synchronize specific lists (described below)
Select the lists you wish to Synchronize by ticking the box next to the list in the “Select for Synchronization” dialog.

Step 3.1: Apply Sync-Filters
You may apply a filter to each list to restrict cached content. Available filters are
e Allfolders or specified folders. All subfolders will also be synchronized.
e Acollection of Views. Contributor will synchronize all content selected in any View.
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Once Synchronization is complete you are ready to start working with the cached content.
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Editing content

Open a document by double-clicking on the item
Right-click on an item to:

Open/Edit a document

Rename content
Delete content

Edit the properties (metadata) of the item.

Check Out; Check In; or Discard Check Out
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New content can be created by selecting the “New” option.
On SharePoint 2007 site content can be created based on content-type templates.
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Uploading existing content

Using “Upload Documents” menu
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Existing content can be added to Contributor by selecting the “Upload” option:
Contributor will prompt for metadata when the document is uploaded.
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Upload content with drag-and-drop

Crasts Cancel

Alternatively you can drag and drop content into Contributor from your desktop. Contributor will accept one or more files or
complete folder structures for uploading. Contributor will prompt for metadata when the items are uploaded.
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Copying existing content

Drag-and-drop

Existing content, files or folder structures, can be copied between SharePoint document libraries or folders by a drag and drop
operation. A new copy of the files or folders is created in the destination location and Contributor will prompt for metadata. In cases
where the metadata structure in the destination library is different from the source library Contributor will make a best effort to
match and retain existing metadata values.

Share Content with other users

Copy SharePoint URL

You can share content with other users by right-clicking on an item and selecting “Copy SharePoint URL”, URLs for the selected
item(s) are copied to your clipboard and can be pasted into many applications, files, or emails.

Drag-and-Drop

Alternatively, for users that do not have access to the SharePoint site it is possible to drag and drop files or folder structures from
the Contributor File Manager into a Windows folder, a file, or as an attachment to an email.
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Default Metadata and Prompting Behavior

Contributor allows you to specify default values for metadata. Default values can be set at a document library, or sub-folder level.
The default values support both inheritance and propagation.

Introducing the Metadata Dialog
A sample of the Default Metadata dialog is displayed below. The following table explains the function of the dialog.

Mllhba:u n.u- ( 1 ]

1. List Selector Panel

2. Default Value Settings

3. Add, Edit and Remove

4. Inherit propagating values from parent
items

-

Clear locally-defined values on all child

£ e ety kS corert Seve

N G A e 1 @ 2

items

BO®

List Selector Panel

Default Value Settings

Add, Edit and Remove

Inherit propagating
values from parent
items

Clear locally-defined

values on all child items

Prompting Behavior

July 28, 2009

6. Prompting Behavior

The List Selector allows you to change the List or Subfolder you wish to work with.
NOTE: The List selector is only visible if the dialog is access through the File menu.

Name The Display Name of the SharePoint column
Value The default value to be applied.
Inherited From Indicates where Contributor receives this value from. The ‘Inherit From’ column

may take the following values:

e SharePoint Column definition

e  <notinherited>
Parent Object Name. This may be the name of a document library of parent
folder.

Apply To Indicates whether the default value may be inherited by a subfolder. The ‘Apply
To’ folder may take the following values:
e  This Folder and subfolders
e  This Folder only

This buttons allow you to work with the locally-defined default values.
Multiple items can be selected for removal using the Windows standard Ctrl and Shift selection
modifiers.

This folder will inherit propagating values from the parent item. Values specified with ‘This Folder
and subfolders’ are propagating values and may be inherited.
When un-checking the option Contributor provides the option to copy inherited values locally.

When settings are applied with this values checked, child-items are reset to inherit values; any user-
specified default values on child-items are cleared.

Modify the prompting behavior. The options are:
e  Always: The metadata prompt will be displayed when an item is added
e  Never: The metadata prompt will *not* be displayed when an item is added
e  According to application global settings: Prompting behavior is as defined in the View->
Options dialog
Child-items that are configured for inheritance will inherit this setting.
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Accessing the Dialog
File Menu
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The file menu may offer different options according to the flavor of Contributor deployed. The Contributor Control Panel interface
may be accessed by double-clicking the Contributor icon in the system tray.
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* When accessed through the File menu, the Default Metadata dialog includes the List Selector Panel.

Context Menus

The Default Metadata dialog may be accessed by right-clicking on a list in the folder area or on a folder in the cached view.
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* When accessed through the context-sensitive menus, the Default Metadata dialog does not include the List Selector
Panel; the dialog applies values to the selected list or subfolder.
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Synchronizing Content

Contributor offers different user-configurable synchronization processes to ensure data is kept synchronized with SharePoint.
Synchronization runs silently in the background allowing you to continue working with your documents.

Automatic Synchronization processes
Colligo Contributor Options =]

General

Synchronize on startup
Contributor synchronizes cached content when it starts

[¥]Prompt for properties when adding documents Synchronize when list is viewed

When you navigate to a list the content is synchronized

[ Use current Windows appearance

Storage I Configurable Synchronization Options . .. .

Siorage loeniiet Synchronized when list is modified
C:\Users\dwhitehead\AppData\Local\Colligo0 | Browse... Modifications include changes to the document or metadata
S¥nE azation Enable background synchronization

|| Synchronize on startup Contributor synchronizes content periodically. The default sync-
[T} synchronize when list is viewed interval is 30 minutes.

[¥] synchronize when list is modified
[¥] Enable background synchronization

Background synchronization interval: 30 minutes

[¥] Automatically download lists to resolve Site Column values

Manual Synchronization processes
e Synchronize Multiple Sites: Allows selection of specific sites to synchronize

e Synchronize All: Synchronizes all sites defined in Contributor
e  Synchronize Pending Changes: Synchronizes lists containing changed content
File | Site | Wiew Help
'Synd i3 Synchronize Al F9

| Issu ‘il Synchronize Pending Changes

Manage Sites...

Full Synchronization

Several of the synchronization processes allow you to specify ‘Full Synchronization”. When Contributor performs a full
synchronization additional information is downloaded, this includes definitions for Sites, Lists, Views and Content-Types, etc, plus
other site-content that may not be retrieved during other standard sync processes.
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Pending Changes Synchronization

You may review content that has changed since the last synchronization by accessing the View->Pending Changes window. For each
item with a pending change you can choose to discard the changes. Discarded changes will be reverted upon the next
synchronization.
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Configuration

Contributor provides easy access to the common configuration options:

PRI SR ST se— L5

For details regarding the Synchronization options please check the Synchronizing Content section.

Prompt for properties when adding documents

By default Contributor prompt for metadata when content is added. This option allows you to disable the prompt. If the prompt is

disabled content is uploaded to SharePoint with default metadata.

Use current Windows appearance

Switch Contributor’s Ul between a Windows application look-and-feel and a WSSv3 style look-and-feel. With the Windows

appearance Contributor will adopt the underlying Windows color scheme.
Standard Appearance
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Storage location

You are able to move the Contributor cache to another location.

Automatically downloads lists to resolve Site Column values
Contributor will ensure that data for Lookup columns is also synchronized.
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