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ColliQo

CONTRIBUTOR™
Add-in for Outlook®

USER GUIDE

Introduction

This User Guide is designed to serve as a brief overview to help you get started. There is also information available under the Help
option in the various Contributor interface toolbar. If necessary you can access the Help by launching the Contributor interface from
the System Tray and selecting Help->Help and Support.

If you would like further instructions, please consult the Features list at http://support.colligo.com/Lists/Features/Allltems.aspx -
where you will find a complete list of features by product along with instructions for use. You will also find a number of screencasts
on the support site that walk you through the main product features. The SharePoint support site can be synchronized with Colligo
Contributor for anytime access, online or offline. Please follow the instructions on the home page at http://support.colligo.com/.

We hope you enjoy using the product, and please don’t hesitate to send us questions or provide feedback at support@colligo.com.
Thank You.
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Installing Colligo Contributor

Systems Supported
e Microsoft Windows Vista: Business; Enterprise; Ultimate. (incl. SP1)
e Microsoft Windows XP Home or Professional
e Microsoft’ Windows 2000 Service Pack 2 or greater
e Microsoft Office 2000 — 2007 (Office 2003 SP2 or later for InfoPath forms)
e Internet Explorer 6.0 or later
e WSS (2.0 or 3.0) and SPS 2003 and MOSS 2007
e  Consumes roughly 20MB of disk space, not including content
e If you have a previous version installed, the new version can be installed “over top” of the old version without needing to
uninstall. This will also preserve all of the cached content.

Application Prerequisites
e  .NET Framework 2.0
For XP or 2000, please ensure the .NET Framework 2.0 is installed first (included with Vista). You can check in the Control
Panel > Add/Remove Program.
e  .NET Framework 3.0
Required to support embedding and extraction of metadata from Office 2007 documents.

Outlook Add-in Prerequisites
e  Compatible version of Outlook (Outlook 2003 or Outlook 2007)
e Office 2003 or Office 2007 Primary Interop Assemblies (depending on which version of Office is installed)
e Microsoft Visual Studio 2005 Tools for Office Second Edition (VSTO 2005 SE) Runtime

Interactive EXE Install

Download the Colligo Contributor EXE installation file to your local computer.

Double-click on the installation file to install Colligo Contributor.

Prerequisites are downloaded and installed.

Enter your license key.

Colligo Contributor can be set to launch at Windows Start Up. This will enable the background synchronization to start
automatically.

Unattended MSI Install
1. Install the required prerequisites.

vk wnN e

2. Download the Colligo Contributor MSl installation file to your local computer.
3. Double-click on the installation file to install Colligo Contributor.
4. Enter your license key.
5. Colligo Contributor can be set to launch at Windows Start Up. This will enable the background synchronization to start
automatically.
Notes

e  Concurrent version installations
Colligo does *not* support side-by-side installations of different versions of Contributor.
ie: itis *not* possible to run multiple versions of Contributor concurrently

e  Version reversion/downgrading
It is *not* possible to revert to an earlier version of Contributor after upgrading. When installing an update to Contributor,
the database is often updated.

e Microsoft. Windows 2000
Microsoft Office’ 2007 is *not* supported on Microsoft” Windows 2000. Contributor does *not* support metadata
embedding and extraction from Office” 2007 documents on Windows 2000 systems.

More detail installation details are available on the support site:
http://support.colligo.com/Lists/Knowledqge%20Base/DispForm.aspx?ID=16
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The Outlook Add-In
Adding a Site to Outlook

It is possible to add a site to Contributor in a number of other ways, including:
Use the “Connect to Outlook” option in Internet Explorer

Site -> Download Site menu option

Click the site selector drop-down and select “Download Site...”

Drag and Drop a URL from IE Into Contributor

The simplest approach is using the “Connect to Outlook” option. This process is described below.

Step 1: IE Toolbar button “Connect to Outlook”

Navigate to a SharePoint List or Library in Internet Explorer
Click the yellow “Connect to Outlook” icon on the toolbar
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Step 2: Confirm the connection in Outlook
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Contributor will start Outlook if it is not already running and confirm that you wish to connect the library to Outlook.

You may choose to connect the List ‘Online’ or ‘Cached’.

Collige Contritsutor Outiock Add-in
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For an introduction to the difference between “Online” and “Cached” read the Contributor Add-In Cached vs Online section of this

document.

You may be prompted for credentials to connect to the SharePoint site.
You may use your default Windows credentials, or supply other specific credentials.

Loge tn “swuppert collos com >
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If the “Connect to Outlook” process is started on a page that does not relate to a SharePoint List you will receive a message box as
shown below. Simply click OK, navigate to a List in IE and click “Connect to Outlook again.

Catigo Contrdsatur Gutionk A L ¥

An error occuered while trying to connect this SharePoint lisz o linrary
to Outlook Please make sure your browses is pointed at 3 SharePoint
bzt oo bbrary, rather than the home page of & SharePoint site
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Step 3: Use the Contributor Add-In

Once Contributor has finished downloading the List definitions the folders are made available in Outlook.
Contributor will build out a tree for the subfolders of the selected document library.

The Online and Cached views are presented below:

Cached View Online View
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Contributor Add-In Cached —vs- Online

Contributor Add-In functions in two ‘Modes’, Online and Cached.

If you attempt connect a list to Outlook that has already been synchronized in Cached Mode Outlook will present the SharePoint
View of the list, however the list will remain synchronized in Cached Mode.

Online Mode

Key functionality of Contributor Add-In operating in Online Mode is:
e Does not maintain a cache of data
Upload content to SharePoint with metadata Prompt
View the SharePoint site in Outlook
Navigate through SharePoint site using Outlook folder tree
Automatically extract Email metadata (To, From, Sent, Subject, etc)

Cached Mode

Key functionality of Contributor Add-In operating in Cached Mode is:
e  Contentis cached providing offline access
e Upload content to SharePoint with metadata Prompt
e Access and Edit existing SharePoint content including accessing metadata.
e  Automatically extract Email metadata (To, From, Sent, Subject, etc)
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Editing content in Cached Mode

Select the folder in Outlook to access the Contributor Add-In Cached-View of the List.

below:
Right-click on an item to:
Open/Edit a document

Rename content

O
o
o
O
o Delete content

Open a document by double-clicking on the item
Edit the properties (metadata) of the item.

Check Out; Check In; or Discard Check Out

User Guide — Colligo Contributor v4.0 Add-in @

The Cached view provides access to the content. Here you can work with your content and perform the actions highlighted
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Creating new content in Cached Mode
New content can be created by selecting the “New” option.

On SharePoint 2007 sites content can be created based on content-type templates
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Uploading existing content
Using “Upload Documents” menu

Existing content can be added to Contributor by selecting the “Upload” option
Contributor will prompt for metadata when the document is uploaded.
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Using Drag-and-Drop

Drag from your Inbox into the Outlook tree

e  Emails can be uploaded to SharePoint simply by drag-and-drop direct from your Inbox into a folder Connected to Outlook.

e  Contributor automatically extracts email metadata (To, From, Sent, Subject, etc) to similarly named SharePoint columns (if they
are defined).

e .msg format maintains fidelity of the message, including attachments

e Unique SharePoint filename generated based on Sender, Sent, and, Subject
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Drag from your Desktop into the Contributor Cached View

Drag from your Desktop into the Outlook tree
Files can be uploaded to SharePoint simply by drag-and-drop direct from your Desktop (or My Computer) into the Outlook
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Files or Folder structures can be uploaded to SharePoint simply by drag-and-drop direct from your Desktop (or My Computer)
into the Contributor Cached View in Outlook
Contributor will prompt for metadata
Contributor uploads the files and folders to the selected library
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Contributor will prompt for metadata
Contributor uploads the file to the selected library
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Drag attachment from an email into the Outlook tree
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e  Attachments can be uploaded to SharePoint simply by drag-and-drop direct from an email into the Outlook folder tree (or

Contributor Cached View).
e  Contributor will prompt for metadata
e Contributor uploads the file to the selected library
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Copying existing content in Cached View

Drag-and-drop
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Existing content, files or folder structures, can be copied between SharePoint document libraries or folders by a drag and drop
operation. A new copy of the files or folders is created in the destination location and Contributor will prompt for metadata. In cases
where the metadata structure in the destination library is different from the source library Contributor will make a best effort to

match and retain existing metadata values.
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Emailing content as an Attachment

Upload Attachment

User Guide — Colligo Contributor v4.0 Add-in 6§D
-,

You can share content with other users by sending them a link (SharePoint URL) to the content rather than an attached file. When
creating an email there is a Contributor toolbar to upload an item and replace it with a link.
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Insert SharePoint URL

You can share content from the cache with other users by using the Insert command. Insert Attachment formats the URL and inserts
it at the top of the body of the email as if it had just been uploaded. Insert Text link inserts the URL at the current cursor location for

inline URLs.
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Attachment Rules

Contributor will prevent emails from being sent if the total size of attachments exceeds a defined limit. .If this limit is exceed then
some attachments may be removed or uploaded to SharePoint and replaced with their URLs. The current limit can be seen with the
Rules command.
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Share Content with other users

Copy SharePoint URL

You can share content with other users by right-clicking on an item and selecting “Copy SharePoint URL”, URLs for the selected
item(s) are copied to your clipboard and can be pasted into many applications, files, or emails.

Drag-and-Drop

Alternatively, for users that do not have access to the SharePoint site it is possible to drag and drop files or folder structures from
the Contributor Cached View into an email, Windows folder, or other suitable application.
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Default Metadata and Prompting Behavior

Contributor allows you to specify default values for metadata. Default values can be set at a document library, or sub-folder level.
The default values support both inheritance and propagation.

Introducing the Metadata Dialog
A sample of the Default Metadata dialog is displayed below. The following table explains the function of the dialog.

Mllhba:u n.u- ( 1 ]

1. List Selector Panel

2. Default Value Settings

3. Add, Edit and Remove

4. Inherit propagating values from parent
items

-

Clear locally-defined values on all child

£ e ety kS corert Seve

N G A e 1 @ 2

items

BO®

List Selector Panel

Default Value Settings

Add, Edit and Remove

Inherit propagating
values from parent
items

Clear locally-defined

values on all child items

Prompting Behavior

July 28, 2009

6. Prompting Behavior

The List Selector allows you to change the List or Subfolder you wish to work with.
NOTE: The List selector is only visible if the dialog is access through the File menu.

Name The Display Name of the SharePoint column
Value The default value to be applied.
Inherited From Indicates where Contributor receives this value from. The ‘Inherit From’ column

may take the following values:

e SharePoint Column definition

e  <notinherited>
Parent Object Name. This may be the name of a document library of parent
folder.

Apply To Indicates whether the default value may be inherited by a subfolder. The ‘Apply
To’ folder may take the following values:
e  This Folder and subfolders
e  This Folder only

This buttons allow you to work with the locally-defined default values.
Multiple items can be selected for removal using the Windows standard Ctrl and Shift selection
modifiers.

This folder will inherit propagating values from the parent item. Values specified with ‘This Folder
and subfolders’ are propagating values and may be inherited.
When un-checking the option Contributor provides the option to copy inherited values locally.

When settings are applied with this values checked, child-items are reset to inherit values; any user-
specified default values on child-items are cleared.

Modify the prompting behavior. The options are:
e  Always: The metadata prompt will be displayed when an item is added
e  Never: The metadata prompt will *not* be displayed when an item is added
e  According to application global settings: Prompting behavior is as defined in the View->
Options dialog
Child-items that are configured for inheritance will inherit this setting.
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Accessing the Dialog
File Menu

The file menu may offer different options according to the flavor of Contributor deployed. The Contributor Control Panel interface
may be accessed by double-clicking the Contributor icon in the system tray.
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Control Panel
* When accessed through the File menu, the Default Metadata dialog includes the List Selector Panel.

Navigation Breadcrumbs

The Default Metadata dialog may be accessed by right-clicking on the navigational breadcrumbs.
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* When accessed through the breadcrumbs, the Default Metadata dialog does not include the List Selector Panel; the
dialog applies values to the selected list or subfolder.

Context Menus

The Default Metadata dialog may be accessed by right-clicking on a list in the quick launch area or on a folder in the cached view.
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* When accesﬁed through thé context-sénsitive menus, the Default Metadata dialog does not include the List Selector
Panel; the dialog applies values to the selected list or subfolder.
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Synchronizing Content

User Guide — Colligo Contributor v4.0 Add-in

Contributor offers different user-configurable synchronization processes to ensure data is kept synchronized with SharePoint.
Synchronization runs silently in the background allowing you to continue working with your documents.
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Automatic Synchronization processes
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Manual Synchronization processes

e Synchronize Specific Site:

Synchronize on startup
Contributor synchronizes cached content when it starts

Synchronize when list is viewed
When you navigate to a list the content is synchronized

Synchronized when list is modified
Modifications include changes to the document or metadata

Enable background synchronization

Contributor synchronizes content periodically. The default sync-
interval is 30 minutes.

Synchronizes the current site

e  Synchronize Multiple Sites: Allows selection of specific sites to synchronize
Synchronizes all sites defined in Contributor

e Synchronize All:
e Synchronize Pending Changes:

Full Synchronization

Synchronizes lists containing changed content
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Several of the synchronization processes allow you to specify ‘Full Synchronization”. When Contributor performs a full

synchronization additional information is downloaded, this includes definitions for Sites, Lists, Views and Content-Types, etc, plus
other site-content that may not be retrieved during other standard sync processes.
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Pending Changes Synchronization

You may review content that has changed since the last synchronization by accessing the View->Pending Changes window. For each
item with a pending change you can choose to discard the changes. Discarded changes will be reverted upon the next
synchronization.
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Configuration

User Guide — Colligo Contributor v4.0 Add-in

Contributor provides easy access to the common configuration options:

4 Lo (erm ey L) b

For details regarding the Synchronization options please check the Synchronizing Content section.

Prompt for properties when adding documents

By default Contributor prompt for metadata when content is added. This option allows you to disable the prompt. If the prompt is

disabled content is uploaded to SharePoint with default metadata.

Use current Windows appearance

Switch Contributor’s Ul between a Windows application look-and-feel and a WSSv3 style look-and-feel. With the Windows
appearance Contributor will adopt the underlying Windows color scheme.

Standard Appearance

b

w g - 4 - & -
Project Tracker
i :
Lty
>
Storage location

You are able to move the Contributor cache to another location.

Automatically downloads lists to resolve Site Column values

Windows Appearance

Contributor will ensure that data for Lookup columns is also synchronized.
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