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Introduction 
Welcome to Colligo Contributor Pro. Easily file, tag, view, and share documents, emails and attachments 
in SharePoint, offline. Colligo Contributor Pro includes Colligo Contributor Add-in for Outlook, Colligo 
Contributor File Manager, and Colligo Contributor Client in a single, value-priced bundle. 

Benefits 
 Empower users to easily manage email and documents in SharePoint 

 Increase the quantity of content captured and tagged in SharePoint 

 Easily access SharePoint from Outlook and Windows Explorer 

 Drive mobile and remote workforce productivity with easy offline access 

 Improve collaboration, and document and project management 

 Reduce risk and improve compliance 

System Requirements 

Software Requirements 
Colligo Contributor requires the following software: 

 Windows XP Professional 

 Windows Vista 

 Windows 7 

 Windows 8 

Client Software Requirements 
Colligo Contributor has the following client software requirements: 

 Microsoft .NET framework 3.5 Runtime 

 Microsoft .NET framework 4.0. Runtime 

 Integration with Microsoft Office requires Office 2003 or later 

 Microsoft Office 2003 SP2, 2007, 2010, 2013 

 Microsoft Office Primary Interop Assemblies (PIAs). Different versions of Office have different PIAs. 
PIAs must be deployed corresponding with the version of Office installed 

 Microsoft Visual Studio 2005 Tools for Office Second Edition (VSTO 2005 SE) Runtime  

 Microsoft Visual C++ 2010 SP1 Redistributable Package 

Server Software Requirements 
Colligo Contributor requires at least one of the following: 

 Microsoft SharePoint Server 2010, MOSS 2007, or SharePoint Portal Server (SPS) 2003 

 Microsoft SharePoint Foundation Microsoft Windows SharePoint Services (WSS) 3.0, or 2.0 

 Microsoft SharePoint 2010 Online (Office365) 

 Microsoft SharePoint 2013 

 Microsoft FAST Search Server 2010 for SharePoint (Optional) 
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Installing Colligo Contributor 
Colligo provides both an .exe installer and an .msi installer for Contributor.  

There are different installer packages dependent on which Operating System you have installed: 

 For a 32-bit Operating System, use the x86 installer 

 For a 64-bit Operating System, use the x64 installer 

To install and activate Contributor File Manager: 
1. Double-click to open the zip file and extract the contents.  
2. In the folder, double-click the folder that corresponds to your operating system:  

a) x64: choose this option if you have a 64-bit operating system 
b) x86: choose this option if you have a 32-bit operating system 

3. Double-click either Setup.exe or .msi.  
4. Follow the steps in the install wizard.  
5. After the install is complete, the following dialog displays:  

 

6. Enter your information to activate the software. If you do not activate Colligo Contributor Pro, it will 
not function.  

Activating Colligo Contributor Pro Manually  
If you are unable to connect to the activation server, the following error message displays:  
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Click Activate via Email to create an activation request file. The following dialog displays: 

 

Click Export Activation Request. This creates a .txt file that you can save anywhere on your machine, 
and then attach to an email that you can send to Colligo to request a manual activation.  

 Concurrent Version Installations 
Colligo does not support side-by-side installations, running multiple versions or different versions of 
Contributor.  

Version Reversion/Downgrading 
It is not possible to revert to an earlier version of Contributor after upgrading as the database is often 
updated.  
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Contributor Client 

Connecting SharePoint Sites 
You can add a SharePoint list or library to Contributor Client in one of two ways: 
 Using the Connect to Contributor option in Internet Explorer 
 Using the Download New Site option 

Using the Connect to Contributor Button 

1. Navigate to a SharePoint List or Library in Internet Explorer. 
2. Click the green Connect to Contributor icon on the toolbar. 

 

3. The Download New Site dialog displays. Select either your default Windows credentials, or supply 
other user-specific credentials. 

 

4. Click Download. 
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The Select for Synchronization dialog displays the lists and libraries you have permissions for: 

 

5. Check the boxes beside the lists and libraries you want to synchronize; use the Check All or Uncheck 
All buttons if needed. 

6. Click Filter to select which folders and views you want to synchronize. 
The Select Filters for Synchronization dialog displays: 
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7. Choose from the following options: 

 Disable Synchronization for this Document Library: choose this option if you do not want 
the document library to be available offline.  

 Synchronize Entire Document Library: choose this option if want to synchronize everything 
in the specified document library.  

 Only synchronize content based on the following filters: choose this option if you want to 
selectively choose what folders and views are synchronized. In the Synchronized Folders 
and Synchronized Views sections, select a folder or view you want to synchronize and click 
Add to move it to the Selected Folders/Views column.  

8. Click OK.  
9. Click Synchronize to download the information for the lists and libraries you have selected. 

Using the Download New Site Option 

To connect a site from within Colligo Contributor Client:  
1. From the Site menu, choose Download New Site:  

  

The Download New Site dialog displays: 

 

2. Enter the URL of the site and enter your default credentials, or user-specific credentials.  
3. See steps 4 to 9 of Using the Connect to Contributor Button. 
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Editing Lists and Libraries  
After you have added your site and chosen which lists and libraries you want to sync, you may want to 
go back at a later time and edit your choices. You can do this in one of two ways: 
1. Right-click a list or library and select Enable Synchronization from the contextual menu. Then 

synchronize the site.  

OR 

1. From the Site menu, choose Download New Site.  
The Download New Site dialog displays: 

 

2. From the Site drop-down list, choose which site you want to configure.  
The Synchronize Site dialog displays: 

 

3. Click Configure.  
4. In the Configure Synchronization dialog, choose which Lists and Libraries you want to sync. 
5. Click OK. 
6. Synchronize the new site.  
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Setting Synchronization Options 
In Contributor Client you can set your Synchronization options to your lists and libraries sync 
automatically. However, you can also perform manually syncs as well.  

Configuring Synchronization Settings 

1. From the View menu, select Options.  
The Colligo Contributor Options dialog displays: 

 

2. In the General section, you can turn on the prompt to record properties about the document by 
checking the Prompt for properties when adding documents box. You can override this setting for 
specific lists/libraries when you are configuring Default Metadata; see Setting Default Metadata. 

3. In the Synchronization section, choose your preferred options: 
a. Synchronize on startup: choose this option if you want your lists and libraries to synchronize 

every time Contributor Client starts  
b. Synchronize when list is viewed: choose this option if you want your lists and libraries to 

synchronize every time you view a list or library  
c. Synchronize when list is modified: choose this option if you want your lists and libraries to 

synchronize every time you modify a list or library  
d. Enable combined check-in and sync: choose this option if you want to combine the step of 

checking in a document and simultaneously syncing it  
e. Enable background synchronization: choose this option if you want to set the 

synchronization to happen in the background on a time-specific basis, and enter your 
preferred time interval 

f. Automatically download lists to resolve Site Column values: if you have lists that reference 
other lists (look-ups), checking this option ensures the related referenced lists are also 
downloaded 

NOTE: Depending on how your IT Administrator has configured the installation, this dialog may not be 
accessible to you, or the synchronization options may be greyed out. 
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Synchronizing Sites Manually 

After you have added your sites, you may want to synchronize them manually, outside of the settings 
you set in the Colligo Contributor Options dialog: 

1. Click the Synchronize menu to display the options: 

 

Choose from the following: 

 Synchronize Site: select this option to synchronize the site currently displayed 

 Synchronize Multiple Sites: select this option to display all sites and choose which ones you 
want to synchronize 

 Synchronize All: select this option to synchronize all sites 

 Synchronize Pending Changes: select this option to synchronize any lists or libraries containing 
changed content 

The Synchronization In Progress dialog displays for any of the above options: 

 

Completing a Full Synchronization 

Several of the synchronization dialogs have a Perform Full Synchronization option. This option means 
that additional information is downloaded, including definitions for Sites, Lists, Views, and Content 
Types, plus other site content that may not be retrieved during other standard sync processes. 
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Viewing and Synchronizing Pending Changes  

You can review content that has changed since the last synchronization and then synchronize it: 

1. From the View menu, select View Pending Changes. 
The Pending Synchronization Changes dialog displays: 

 

2. To discard the changes for a particular item, right-click it and choose Discard Changes. Discarded 
changes are reverted upon the next synchronization. 

3. Click Synchronize. 

  



Colligo Contributor Pro - Contributor Client 

12/02/2013 Copyright 2013 Colligo Networks, Inc.  All rights reserved. 
Not to be reproduced without permission. Learn more at www.colligo.com. 

Page 13 of 49 

 

Viewing, Editing, and Creating Content 
After you have added and synchronized your lists and libraries, the content is cached (available offline). 
You can open, edit, rename, and delete SharePoint items, and check items in and out of SharePoint. 

The Tree View in Contributor Client allows you to view content more dynamically and to move and copy 
content between folders in the same SharePoint site using drag-and-drop. You can change the view by 
enabling or disabling the Tree View option in the View menu:  

 

NOTE: you cannot enable or disable synchronization of document libraries or lists while Tree View is 
enabled. If you want to do this, you must turn off Tree View and work in List View.  

NOTE: If the Tree View option is not available to you, it has been disabled by your IT Administrator.  

Viewing Content 
After you have added and synchronized your sites, the libraries you have chosen to sync display in the 
left pane under the Site Collection heading; the contents of a selected library display in the right pane: 
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If Tree View is enabled, you can expand and contract folders in the left pane to navigate to the 
SharePoint location you are looking for. The folder that is highlighted in the Tree View indicates the 
SharePoint location you are currently are viewing.  

 

To view an item, double-click it to launch it in the item’s native program. If the item is checked out by 
another user, it opens in Read-Only mode.  

  



Colligo Contributor Pro - Contributor Client 

12/02/2013 Copyright 2013 Colligo Networks, Inc.  All rights reserved. 
Not to be reproduced without permission. Learn more at www.colligo.com. 

Page 15 of 49 

 

Editing Content 
To edit an item, double-click it to open it in the item’s native program. You can then edit the item as 
preferred, save it, and close it.  

The changes are uploaded to SharePoint the next time the list/library is synchronized.  

NOTE: you cannot edit an item if it is checked out by another user. If the item is checked out, a red 
arrow icon displays on the item: 

 

Resolving Editing Conflicts 

If another user has opened the document, edited it, and uploaded it to SharePoint, and you try to 
upload the same document with your changes, the following dialog displays: 

 

You can click Open to view the edits in each version, and then click one of the following options: 

 Choose Local Version: if you choose this option, the version on your local machine overwrites 
the current version on SharePoint 

 Merge Versions: If you choose this option, a wizard displays and walks you through a process to 
choose the changes you want to keep or discard  

 Choose Server Version: if you choose this option, the version on SharePoint does not change; 
you are effectively discarding your version 
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Editing Item Properties 

To edit the properties of an item, right-click it and choose Edit Properties: 

 

The Edit Properties dialog displays. Edit as preferred and click Close.  

The changes are uploaded to SharePoint the next time the list/library is synchronized.  

NOTE: you cannot edit an item’s properties if it is checked out by another user. If the item is checked 
out, a red Check Out icon displays on the item. 
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Checking Items In or Out 

To check an item in or out, right-click it and choose Check Out/In. The Check In option only displays if 
you have previously checked the item out. 

 

Once you have checked an item out, the Check Out icon is overlaid on top of the document type icon, so 

users can see that the item is being edited:  

After you have checked the item out, you can open it, edit it, and then check it back in to the list/library. 
The changes are uploaded to SharePoint the next time the list/library is synchronized.  

NOTE: If you try to check out an item that has been modified in SharePoint and not synchronized, the 
following message displays:  

 

You need to close the dialog, synchronize the site so you have the most up-to-date version of the 
document, and then perform the Check Out operation again.  

To avoid the above conflict, select the combined check-in and sync option as described in Error! 
eference source not found..  
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Renaming Items 

To rename an item, right-click it and select Rename.  

 

The item name becomes editable. Edit as preferred, and press Enter to complete the change.  

The change is reflected in SharePoint the next time the list/library is synchronized.  

NOTE: you cannot rename an item if it is checked out by another user. If the item is checked out, a red 
Check Out icon displays on the item. 

Deleting Items  

To delete an item, right-click it and select Delete.  

The change is reflected in SharePoint the next time the list/library is synchronized. 

NOTE: you cannot delete an item if it is checked out by another user. If the item is checked out, a red 
check-out icon displays on the item. 
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Creating New Content 
In addition to editing existing content in SharePoint, you can also add new content to your synchronized 
lists and libraries. 

You can add items to Contributor Client in one of the following ways: 

 Create new documents from within the Contributor Client interface 

 Upload existing content 

 Drag-and-drop or copy-and-paste content 

When you are adding content from your Windows desktop or directory to SharePoint using the Client 
interface, the content is always copied to SharePoint. When you are moving content from one 
SharePoint location to another within the Client interface you have the option to move or copy the 
content; see Moving or Copying Content within SharePoint.  

Adding a New Document to a List/Library 

To add a new document to a list or library: 
1. With the list or library you want to add the document to selected, click the New menu and select 

your preferred document type from the drop-down list:  
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The Create New Document dialog displays: 

 

2. Choose your document type from the Site Templates tab or the Other tab. 
3. Enter a name for the document, and click Create.  

The New Item dialog displays. This is where you can record information about the document that is 
stored in SharePoint as well as choose the location of the document (click Folder to browse the 
folders and subfolders in the list or library).  

4. Edit the New Item dialog as preferred.  

 

5. Click Create. The document is added to the SharePoint location. 
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Using the Upload Documents Dialog 

To add an existing document to a list or library: 
1. With the list or library you want to add the document to selected, click the Upload menu, and 

choose Upload Documents: 

 

The Upload Documents dialog displays.  
2. Browse to the document that you want to upload, and click Open. To select more than one 

document, use Ctrl + click.  
3. The New Item dialog displays. Edit as preferred and click Create. 

The document is added to the SharePoint location. If you have selected more than one document, 
any properties you assign apply to all items.  

Dragging-and-Dropping Content 

You can drag-and-drop one or more files or complete folder structures into Contributor Client from your 
Windows desktop or from other directory locations.  
1. Drag-and-drop your preferred files or folders from your desktop or another directory to your 

preferred SharePoint location in Contributor Client.  
2. The New Item dialog displays. Edit as preferred and click Create. The file or folder is added to the 

SharePoint location. If you have selected more than one document or a folder, any properties you 
assign apply to all items.  

 

  



Colligo Contributor Pro - Contributor Client 

12/02/2013 Copyright 2013 Colligo Networks, Inc.  All rights reserved. 
Not to be reproduced without permission. Learn more at www.colligo.com. 

Page 22 of 49 

 

Moving or Copying Content within SharePoint 
You can move or copy content from one location in SharePoint to another location, through the 
Contributor Client interface.  

NOTE: this feature is disabled by default. Contact your IT Administrator. 

1. Select one or more files in a library or folder, and drag-and-drop it to another folder. 
The New Item dialog displays.  

2. Edit as preferred and click Create. 
The following dialog displays: (new screenshot needed)  

 

3. Click Move or Copy. Note that no version history, timestamps, or original author information is 
preserved in either the Move or Copy action. If you choose to move an item, the original file is 
deleted. In addition, any metadata associated with the original file will not be preserved and you will 
need to enter new metadata for the item. 

NOTE: You cannot move an item that is checked out by another user. If you attempt to do this, the 
following error message displays: 

 

If you hover your mouse over the item, a message displays telling you who has the item checked 
out. That user needs to check the item back in before you can move the item.  
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Contributor Add-In for Outlook 

Adding SharePoint Lists and Libraries to Outlook 
You can add a SharePoint list or library to Contributor Add-in for Outlook in one of two ways: 
1. By using the SharePoint Sites dialog in Outlook. 
2. By using the Connect to Outlook button in Internet Explorer. 

Using the SharePoint Sites dialog in Outlook 

To connect a site from within Outlook: 
1. Click the Download icon in the Colligo For SharePoint group in the Home ribbon in Outlook.  

 

The Connect Document Library dialog displays: 

 

2. Click Download new site.  
The Download New Site dialog displays: 
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3. Enter the URL of the site and use your default credentials, or user-specific credentials.  
4. Click Download. The site displays in the Connect Document Library dialog. 
5. Click Next. A list of all lists and libraries in the site displays: 

 

6. Select the list or library you want to display in Outlook. If you want the list or library to be cached 
(available offline) check the Enable local caching for this list or document library box.  

7. Click Finish. The list or library displays in the Colligo for SharePoint list in your Outlook folder tree.  
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Using the Connect to Outlook Button in Internet Explorer 

You can add a SharePoint list or library to Contributor Add-in for Outlook directly from Internet Explorer 
using the Connect to Outlook button. 

To add a site with the Connect to Outlook button: 
1. Navigate to the SharePoint list or library that you want to add as a folder in Outlook, and click the 

Connect to Outlook button: 

Internet Explorer 9 

 

NOTE: If the Connect to Colligo Outlook button is not visible, you need to enable the Command bar. 

Internet Explorer 8 

 
The following dialog displays: 

 

2. Check the Enable local caching for this list or document library box if you want the list or library to 
be cached (available offline). 

3. Click Yes. The list or library displays in the Colligo for SharePoint list in your Outlook folder tree. 

NOTE: If you click the Connect to Outlook button when you’re on a SharePoint page that is not a list 
or library, the following message displays:  
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4. Click OK, then navigate to a list or library in Internet Explorer and click Connect to Outlook again. 

Viewing Lists and Libraries in Outlook  

Click on an Outlook folder under the Colligo for SharePoint group to display the selected SharePoint 
location.  

The folder location displays in one of two modes: Cached or Online. 

Cached View 

 

Online View 

 

Online mode and cached mode have similar functionality, except that for the online view, the content is 
not cached (available offline). Both modes allow you to do the following: 

 Upload content to SharePoint with metadata Prompt 

 View the SharePoint site in Outlook 

 Automatically extract Email metadata (To, From, Sent, Subject, etc.) 

 Access and Edit existing SharePoint content including accessing metadata. 

To refresh the content, click the Refresh Folders icon in the Colligo For SharePoint group in the Home 
tab in Outlook.  
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Configuring your Synchronization Settings 
The settings for how frequently your content is synchronized are set in the Options dialog.  

1. From the View menu, select Options. 
The Colligo Contributor Options dialog displays: 

 

2. In the General section, you can turn on the prompt to record properties about the document by 
checking the Prompt for properties when adding documents box. You can override this setting for 
specific lists/libraries when you are configuring Default Metadata; see Setting Default Metadata. 

3. In the Synchronization section, choose your preferred options: 
a. Synchronize on startup: choose this option if you want your lists and libraries to synchronize 

every time Contributor Client starts  
b. Synchronize when list is viewed: choose this option if you want your lists and libraries to 

synchronize every time you view a list or library  
c. Synchronize when list is modified: choose this option if you want your lists and libraries to 

synchronize every time you modify a list or library  
d. Enable combined check-in and sync: choose this option if you want to combine the step of 

checking in a document and simultaneously syncing it  
e. Enable background synchronization: choose this option if you want to set the 

synchronization to happen in the background on a time-specific basis, and enter your 
preferred time interval 

f. Automatically download lists to resolve Site Column values: if you have lists that reference 
other lists (look-ups), checking this option ensures the related referenced lists are also 
downloaded 

NOTE: Depending on how your IT Administrator has configured the installation, this dialog may not be 
accessible to you, or the synchronization options may be greyed out. 
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Synchronizing Content Manually 

To manually synchronize your SharePoint content: 

1. Click the Synchronize icon in the Colligo For SharePoint group in the Home ribbon in Outlook: 

 

The Synchronize SharePoint Content dialog displays: 

 

2. Check the boxes of the sites you want to synchronize, or use the Check All or Uncheck All buttons to 
set your preferences.  

3. Click Synchronize. 

Completing a Full Synchronization 

Several of the synchronization dialogs have a Perform Full Synchronization option. A full 
synchronization downloads additional information. This includes definitions for Sites, Lists, Views, and 
Content Types, plus other site content that may not be retrieved during other standard sync processes. 
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Filing Items to SharePoint Folders 
You can file emails and documents to your SharePoint folders in Outlook in a number of different ways.  

Dragging-and-Dropping Emails 

You can upload one or multiple emails to SharePoint by dragging-and-dropping them from your inbox to 
a SharePoint location in your Outlook folder tree. You can also drag-and-drop other documents from 
your desktop or a Windows Explorer folder location.  

Each time you file something to a SharePoint folder in Outlook, the metadata editor displays: 

 

Edit the metadata fields as preferred and click Create to complete the upload process.  

Move Versus Copy 

When you drag-and-drop an item into a folder, it is either moved or copied to SharePoint. If it’s moved, 
the email no longer exists in your Outlook. If it’s copied, it exists both in SharePoint and in Outlook.  

The default behavior when using the drag-and-drop action is Move. If you want to Copy the item to 
SharePoint, you can do one of the following: 

 left-click and press Ctrl until you let go of the click  

 right-click: when you let go of the click, the following dialog displays, giving you the option to Copy 

 

NOTE: attachments are copied to SharePoint and remain as part of the email. 
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Sending-and-Filing Emails 

When you’re creating a new email, you can use the Send & File button to send your email and file it at 
the same time. 

1. Click the Send & File button, the Colligo Send & File dialog displays: 

  

2. Browse to the location you want to file the email to and double-click to select the folder and send 
the email.  

Using the Copy Folder 

You can upload whole folders and their contents (including subfolders) from your mailbox to SharePoint.  

1. Click the Copy icon in the Colligo For SharePoint group in the Home ribbon in Outlook: 

 

The Copy Outlook Folder dialog displays: 
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2. In the Select Folder to Copy panel, choose the folder that you want to copy to one of your 
SharePoint locations.  

3. In the Select Destination panel, choose the SharePoint location to copy the folder to.  
4. In the Copy Options section, choose if you want to include the top-level folder and/or any 

subfolders. 
5. Click OK.  
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Working with Content in Cached Mode  
Many SharePoint actions are available in the cached (offline) mode. 

Right-click on an item to: 

 Edit the properties  

 Open/Edit  

 Check Out, Check In, or Discard Check Out 

 Rename content 

 Delete content 
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Creating New Content  

To create new content in a cached folder: 
1. Click the New drop-down menu: 

 

2. Select the New Document option to display the Create New Document dialog: 

 

3. Choose your document type from the Site Templates tab or the Other tab. 
4. Enter a name for the document, and click Create.  
5. The Edit Properties dialog displays. Edit as preferred. 

The new document is added to the list or library. 
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Uploading Existing Content 

To upload existing content to a cached folder: 
1. Click the Upload drop-down menu and select Upload Documents: 

 

The Upload Documents dialog displays. 

2. Browse to the location of the document you wish to upload and click Open.  
3. The Edit Properties dialog displays. Edit as preferred and click Create.  

The new document is added to the list or library. 
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Using the Colligo Attachment Manager 
Colligo Contributor Add-in for Outlook has an Attachment Manager tool that gives you a number of 
ways to share and manage your SharePoint content. 

Uploading an attachment to SharePoint 

If you want to send someone a document, but you would rather send a link to a SharePoint location 
instead of an attachment, you can upload the document to SharePoint and insert a link to the location 
into your email. You can do this from Outlook using Colligo’s Attachment Manager.  

When you launch a new email, the Colligo Attachments group displays in the Message ribbon: 

 

NOTE: The Colligo Attachments group only displays in the Message ribbon of a new email; it does not 
display anywhere else in Outlook.  

1. Click Upload to display the Upload Attachments to SharePoint dialog: 
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2. In the Choose Files section, click Add and browse to the location of the document(s) you want to 
upload. 

3. In the Destination Site section, click Choose Destination and select the Site, Library, and Folder you 
want to upload your documents to.  

4. Click OK. The New Item dialog displays.  
5. Enter any properties and click Create.  

The document is uploaded to your specified location, and a link to the document’s location is inserted 
into the body of your email:  

 

Inserting a Link to a Document in SharePoint  

If the document you want to share is in SharePoint, you can insert a link to the document in your email. 

To insert a link to an item in SharePoint: 
1. Click Insert in the Colligo Attachments group in the Message ribbon and choose either Attachment 

Link or Text Link.  

NOTE: The Attachment link displays the full path of the SharePoint location, while the Text link 
displays only the name of the file.  

The Link to SharePoint Content dialog displays: 
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2. Browse through the SharePoint libraries to find the document you want to link to, and click Insert.  

The links display as follows: 
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Setting Attachment Rules 

You can configure rules for the size of your attachments that correspond to your organization’s email 
policies to display a prompt when you have an attachment exceeding a certain size, or to block sending 
an email when an attachment exceeds a specified size.  

To configure the rules: 
1. Click Rules in the Colligo Attachments group to display the Colligo Attachment Manager dialog: 

 

2. In the field Prompt when sending emails with total attachment size great than (Kb), enter the limit 
for the size of the attachment. If you attempt to send an email that has an attachment greater than 
the number you have specified in this field, the following dialog displays: 

 

Choose from one of the following options: 
a) Send Anyway: choose this option to ignore the warning and send the email as configured 
b) Upload to SharePoint: choose this option to display the Upload Attachments to SharePoint 

dialog and choose the location in SharePoint you want to upload the attachment to 

3. In the field Block when sending emails with total attachment size great than (Kb),  enter the limit 
for the size of the attachment. If you attempt to send an email that has an attachment greater than 
the number you have specified in this field, the following dialog displays: 

 

4. Click OK and the Upload Attachments to SharePoint dialog displays.  
5. Choose the upload destination and click OK. The item is uploaded and a link to the SharePoint 

location is inserted into your email. 
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Contributor File Manager 

Connecting SharePoint Sites 
You can add a SharePoint list or library to Contributor File Manager in one of two ways: 
 Using the Connect to Contributor option in Internet Explorer  
 Using the Download New Site option 

Using the Connect to Contributor Button 

1. Navigate to a SharePoint List or Library in Internet Explorer. 
2. Click the green Connect to Contributor icon on the toolbar. 

 

3. The Download New Site dialog displays. Select either your default Windows credentials, or supply 
other user-specific credentials. 

 

4. Click Download. 
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The Select for Synchronization dialog displays the lists and libraries you have permissions for: 

 

5. Check the boxes beside the lists and libraries you want to synchronize; use the Check All or Uncheck 
All buttons if needed. 

6. Click Filter to select which folders and views you want to synchronize. 
The Select Filters for Synchronization dialog displays: 
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7. Choose from the following options: 

 Disable Synchronization for this Document Library: choose this option if you do not want 
the document library to be available offline.  

 Synchronize Entire Document Library: choose this option if want to synchronize everything 
in the specified document library.  

 Only synchronize content based on the following filters: choose this option if you want to 
selectively choose what folders and views are synchronized. In the Synchronized Folders 
and Synchronized Views sections, select a folder or view you want to synchronize and click 
Add to move it to the Selected Folders/Views column. 

8. Click OK.  
9. Click Synchronize. The site displays under the Colligo File Manager group in Windows Explorer.  

Using the Download New Site Dialog 

To connect a site from the Windows Explorer interface:  
1. Right-click the Colligo File Manager node and select Download New Site from the contextual menu.  

 

The Download New Site dialog displays: 

 

2. Enter the URL of the site and use your default credentials, or user-specific credentials.  
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3. Click Download.  

The site displays under the Colligo File Manager node in Windows Explorer. However, the site’s lists 
and libraries are not synchronized at this point and display as greyed out in Windows Explorer.  

4. To synchronize a list or library, right-click it and select Enable Synchronization. To select filters for 
synchronization, right-click a list or library and select Filter Synchronization.  

 

After you have enabled synchronization and set your filters, you need to start the synchronization 
process. You can do this in one of two ways:  

 Right-click the Contributor File Manager icon in the system tray and choose Synchronize All: 

 

 From the Site menu in the Contributor File Manager Control Panel, choose one of the following 
options: 

o Synchronize Multiple Sites: choose this option to synchronize more than one site. In the 
Synchronize Multiple Sites dialog, check your preferred sites and click Synchronize. 

o Synchronize All: choose this option to synchronize all sites 
o Synchronize Pending Changes: choose this option to synchronize changes you have 

made 
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5. The Synchronization In Progress dialog displays for any of the above options: 
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Configuring Synchronization Settings 
The synchronization settings for Contributor File Manager are set in the Options dialog: 
1. From the View menu, select Options.  

The Colligo Contributor Options dialog displays: 

 

2. In the General section, you can turn on the prompt to record properties about the document by 
checking the Prompt for properties when adding documents box. You can override this setting for 
specific lists/libraries when you are configuring Default Metadata; see Setting Default Metadata. 

3. In the Synchronization section, choose your preferred options: 
a. Synchronize on startup: choose this option if you want your lists and libraries to synchronize 

every time Contributor Client starts  
b. Synchronize when list is viewed: choose this option if you want your lists and libraries to 

synchronize every time you view a list or library  
c. Synchronize when list is modified: choose this option if you want your lists and libraries to 

synchronize every time you modify a list or library  
d. Enable combined check-in and sync: choose this option if you want to combine the step of 

checking in a document and simultaneously syncing it  
e. Enable background synchronization: choose this option if you want to set the 

synchronization to happen in the background on a time-specific basis, and enter your 
preferred time interval 

f. Automatically download lists to resolve Site Column values: if you have lists that reference 
other lists (look-ups), checking this option ensures the related referenced lists are also 
downloaded 

NOTE: Depending on how your IT Administrator has configured the installation, this dialog may not be 
accessible to you, or the synchronization options may be greyed out. 
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Completing a Full Synchronization 

Several of the synchronization dialogs have a Perform Full Synchronization option. This option means 
that additional information is downloaded, including definitions for Sites, Lists, Views, and Content 
Types, plus other site content that may not be retrieved during other standard sync processes. 

Creating New Content 

After you have added your sites and synchronized your lists and libraries, the content is cached 
(available offline). You can now open and edit SharePoint items, check items in and out of SharePoint, as 
well as rename and delete items. 

You can add items to Contributor File Manager in one of the following ways: 

 Add a new document from within the Contributor File Manager interface 

 Upload existing content 

 Drag-and-drop or copy-and-paste content 

 Use the File > Save As command 

Adding a New Document to a List/Library 

From within Windows Explorer, you can create and add a new document to a SharePoint location: 
1. From the File menu, choose New > New Document: 

 

NOTE: if you cannot see the File menu, press the Alt key to display it.  
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The Create New Document dialog displays: 

 

2. Choose your document type from the Site Templates tab or the Other tab. 
3. Enter a name for the document, and click Create.  

The New Item dialog displays.  

 

4. This dialog is where you can record information about the document. Edit as preferred. 
5. Click Close. The document is added to the SharePoint location. 

Using the Upload Documents Dialog 

From within Windows Explorer, you can upload existing documents to your preferred SharePoint 
location: 
1. From the File menu, choose Upload Documents:  
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NOTE: if you cannot see the File menu, press the Alt key to display it.  

The Upload Documents dialog displays.  
2. Browse to the document that you want to upload, and click Open. To select more than one 

document, use Ctrl + click.  
3. The New Item dialog displays. Edit as preferred and click Create.  

The document is added to the SharePoint location. If you have selected more than one document, 
any properties you assign apply to all items.  

Dragging-and-Dropping Content 

You can drag-and-drop one or more files or complete folder structures into File Manager from your 
desktop or from other directory locations: 
1. Drag-and-drop your preferred files or folders from your desktop or another directory to your 

preferred SharePoint location in Contributor File Manager.  
2. The Edit Properties dialog displays. Edit as preferred and click Create. 

The file or folder is added to the SharePoint location. If you have selected more than one document 
or a folder, any properties you assign apply to all items.  
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Using the File Save As Command 

You can use the File > Save As command from integrated programs to save directly into any of the 
SharePoint lists or libraries you have connected to Contributor File Manager: 
1. In your open document, select File > Save As. 
2. In the Save As dialog, navigate to your SharePoint location, edit the file name as needed, and click 

Open: 

 

3. The Edit Properties dialog displays. Edit as preferred and click Close.  
The document is added to the SharePoint location.  

Copying a SharePoint URL 

You can share content with other users by right-clicking on an item and selecting Copy SharePoint URL. 
The URLs for the selected items are copied to your clipboard and can be pasted into applications, files, 
or emails. 
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Setting Default Metadata 
If you want to tag all documents and items that you add or upload to a list or library with the same 
metadata, you can set default metadata values through the Contributor Client interface: 

1. From the File menu, choose Default Metadata Values.  
The Default Metadata Values dialog displays:  

 

2. Select the site and library/list that you want to configure.  
3. To add a metadata tag, click Add.  

The Add Default Meta data Properties dialog displays, displaying the metadata field options that 
are set in the document library in SharePoint.  

 

4. Enter your preferred tags and click Add.  
5. If you want the values to propagate to any subfolders, check the Propagate these default metadata 

values to subfolders box.  
6. To configure the metadata prompt behavior, choose a radio button on the right under the When 

adding documents, prompt for properties section: 

 Always 

 Never 

 According to application global settings (as set in step 2 of Configuring Synchronization 
Settings) 


