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Colligo Contributor File Manager

Introduction

Welcome to Colligo Contributor File Manager, the program that helps increase SharePoint adoption by
seamlessly linking your SharePoint document libraries to the familiar Windows Explorer interface. Local
folders become “SharePoint aware,” providing easy access to SharePoint features such as metadata,
content types, and document templates. Folders can also be easily accessed from any application that
uses the standard Windows File Open/Save dialog. SharePoint files can be added and edited using
familiar desktop operations.

Benefits

Colligo Contributor File Manager helps:

e Empower users to easily manage email and documents in SharePoint

e Increase the quantity of content captured and tagged in SharePoint

e Make SharePoint accessible directly from the desktop

e Drive mobile and remote workforce productivity with easy offline access
e Improve collaboration, and document project management

e Improve records retention to reduce risk and improve compliance

Features

Colligo Contributor File Manager lets you:

e Drag-and-drop documents to SharePoint

e Navigate to cached SharePoint content

e Sync documents, document sets, libraries, or entire SharePoint sites

e Open, save, organize, and classify SharePoint files directly from Windows Explorer

Platforms Supported

e  Microsoft SharePoint Server 2010, MOSS 2007, SharePoint Portal Server (SPS) 2003
e SharePoint Foundation Microsoft Windows SharePoint Services (WSS) 3.0, or 2.0

e SharePoint 2010 Online (Office365)

e SharePoint 2013

e QOutlook 2007, 2010, 2013 Preview (32-bit and 64-bit)

e Windows XP Professional, Windows Vista, Windows 7, Windows 8
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Installing and Activating Contributor File Manager

To install and activate Contributor File Manager:

1. Double-click to open the zip file and extract the contents.

2. Inthe folder, double-click the folder that corresponds to your operating system:
a) x64: choose this option if you have a 64-bit operating system
b) x86: choose this option if you have a 32-bit operating system

3. Double-click either Setup.exe or .msi.

4. Follow the steps in the install wizard.

5. After the install is complete, the following dialog displays:

Activate Colligo Contributer @

Welcome to Colligo Contributor!

To start using this software, please activate it while connected to the
Internet. Providing your email address will ensure you periodically
receive product notices, version releases, and our newsletter, Your
personal privacy is important to us - your information will never be
shared with a third party.

Click here to view our Privacy Statement.

RegistrationInformation

MName: |

Organization: |

Email: |

Activate | Exit ‘

6. Enter your information and click Activate.
After Contributor File Manager is installed, a new group called Colligo File Manager displays as a
location in Windows Explorer:

=REC X
@Qvt‘.i » Computer » - |$’| | Search Computer 0 |
Organize « Properties System properties Uninstall or change a program Map network drive 2 i,‘:: ~ [ 'a'
a4 Librari -~ . .
mlefErlES 4 Hard Disk Drives (2)
» = Documents
h . Local Disk (C:) DATA (D)
g J Music — . — -
> [ Pictures 434 GB free of 111 GB S 711 GBfrecof745GB
> B videos 4 Devices with Removable Storage (2)
> B
T &oa &4
“1 = Computer £ DVD RW Drive (E2) DVD Drive (F:)
» ey Local Disk () = =
> ca DATA (D) 4 Other (1)

> i DVD RW Drive (E)

P 2T,
> 42 DVD Drive (F) (. “ Colligo File Manager
hI=wyy System Folder

4 (@ Colligo File Manager

» Ly Colligo Portal
> €M Network
>[5 Control Panel 2

i Local Disk (C:) Space used: Total size: 111 GB
- Local Disk Space free: 43.4 GB File systerm: NTFS

1 item selected

J

NOTE: If the Colligo File Manager icon is not visible in Windows Explorer after installation, you may need
to configure your options. See the following Knowledge Base article for instructions:
http://www.colligo.com/support/kb/file-manager-icon-not-visible-in-windows-explorer/
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Activating Contributor File Manager Manually

If you are unable to connect to the activation server, the following error message displays:

-
Activate Collige Contributor l&J

d '~ | Activation Failed

L " The Collige Activation Server was not reachable, Activation
will be attempted the next time you use the software.
Alternately, you can choose to activate through email,

Activate via Emai | Activate Later |

Click Activate via Email to create an activation request file. The following dialog displays:

Activate Collige Contributor [&J

To activate Colligo Contributor File Manager via email, dick
"Export Activation Request™, An activation request file will be
generated, which you can then email to Colligo Technical Support
where your activation request will be fulfiled.

Email Colligo Support: support@colligo.com

| Export Activation Request | Exit |

L S

Click Export Activation Request. This creates a .txt file that you can save anywhere on your machine,
and then attach to an email that you can send to Colligo to request a manual activation.

Using the Contributor File Manager Control Panel

The other part of Contributor File Manager is the Control Panel. This is a separate interface that displays

in its own window. From here you can locate and configure options and see any sync issues such as
conflicts or files being locked.
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To display the Control Panel, open Colligo Contributor from your Start menu or from the system tray
icon:

(@ Collige Contributor File Manager = | B
Flle Site  View Help
Sync Issues
Issue Item Site: List Folder
‘ \ o
'@) Mo Synchronization Activity

Checking for Updates

In the Contributor File Manager Control Panel, you can check if you are using the most current version of

the program:

1. From the Help menu, select Check for Update. The www.colligo.com site launches.

2. |If there is a newer version available, click the Download the latest version now link to install the
newer build.

Updating Your License Key

In the Contributor File Manager Control Panel, you can change your license key:
1. From the Help menu, select Install License Key.
2. The Enter License Key dialog displays. Enter your new license key and click OK.

Enter License Key &J

Flease enter your 25-digit license key (indude dashes):

Cancel
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Connecting SharePoint Sites

Colligo Contributor File Manager

You can add a SharePoint list or library to Contributor File Manager in one of two ways:

e Using the Connect to Contributor option in Internet Explorer

e Using the Download New Site option

Using the Connect to Contributor Button

1. Navigate to a SharePoint List or Library in Internet Explorer.
2. Click the green Connect to Contributor icon on the toolbar.

http://vs-sp2010/PM/Shared%20Docume 2 ~ & X

File Edit View Favorites Tools Help

Shared Documents - All Do...

i v B v [ dm v Pagev Safetyv Tooksv @+ @i N @ (v 53 @

Library Tools

Site Actions ~ @l TSNS Documents Library

Connect to Contributor

3. The Download New Site dialog displays. Select either your default Windows credentials, or supply

other user-specific credentials.
o Download New Site @

Site: | <New Site> |

URL: D 5P

Examples:  http:/fserver fworkspace
https: /fsecureserver fworkspace

Server Authentication
(¥ Use default credentials
" Use the following credentials:

User name: |

Password: |

Download | Close

o A

4, Click Download.
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The Select for Synchronization dialog displays the lists and libraries you have permissions for:

' ™
Select for Synchronization u

—Document Libraries and Lists

" Synchronize all document libraries and lists
& Synchronize the following:

E Announcements

[ calendar

[=] Links

3| Private Documents

[Tl Product Lifecycle Dashboard
[1] release Dashboard

i3] Shared Documents

23| Site Assets

3] Site Pages

[ [E]Tasks

[ I R e |

Click the chedkbox to enable or disable synchronization for H

the spedfied list. H
Checkal |  Unchedcal | Fiter... |
Synchronize I Close |
A A

Check the boxes beside the lists and libraries you want to synchronize; use the Check All or Uncheck
All buttons if needed.

Click Filter to select which folders and views you want to synchronize.
The Select Filters for Synchronization dialog displays:

' ™
Select Filters for Synchronization u

" Disable Synchronization for this Document Library
~ Synchronize Entire Document Library
" Only synchronize content based on the following filters:

—Synchronized Faolders
Available Folders Selected Folders

B3y
[C3 Arakelyan et al v, Contoso LLC

\ [C3 ICE Co vs Contoso
Add == |

Remove

|

—Synchronized Views

Selected Views I

[T7] All Documents

[T My Matters Add == |
,j Recent Documents
Remove |

Cancel Filker Refresh QK Cancel
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7. Choose from the following options:
e Disable Synchronization for this Document Library: choose this option if you do not want
the document library to be available offline.

e Synchronize Entire Document Library: choose this option if want to synchronize everything
in the specified document library.

e Only synchronize content based on the following filters: choose this option if you want to
selectively choose what folders and views are synchronized. In the Synchronized Folders
and Synchronized Views sections, select a folder or view you want to synchronize and click
Add to move it to the Selected Folders/Views column.

8. Click OK.

9. Click Synchronize. The site displays under the Colligo File Manager group in Windows Explorer.

Using the Download New Site Dialog

To connect a site from the Windows Explorer interface:
1. Right-click the Colligo File Manager node and select Download New Site from the contextual menu.

Organize «

* || Pictures

> B Videos Collige Intranet Colligo Portal
4 )
4 M Computer

,i_‘_{‘ Local Disk (C2) Product Management

»w DATA(D:)

> e DVD RW Drive (E:)
> e DVD Drive (F) =
4 '@ Colligo File Manager
» Ly Colligo Intranet Collapse

> s Colligo Portal Open in new window
> Ly Product Managemen

>‘=‘j Metwork

>[5 Control Panel

£ Recycle Bin 2

Download New Site...

Product Management

o

L8

The Download New Site dialog displays:
f 4 Download New Site @1

URL:

Examples: http: [fserver fworkspace
https: f{secureserver jworkspace

Server Authentication
(@) Use default credentials
() Use the following credentials:

User name:

Password:

Download Cancel

e -

2. Enter the URL of the site and use your default credentials, or user-specific credentials.
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Click Download.

The site displays under the Colligo File Manager node in Windows Explorer. However, the site’s lists
and libraries are not synchronized at this point and display as greyed out in Windows Explorer.

To synchronize a list or library, right-click it and select Enable Synchronization. To select filters for
synchronization, right-click a list or library and select Filter Synchronization.

Organize »

= Pictures 0 Name
B videos
a
18 Computer
£, Local Disk (C)
a DATA (D)
L) DVD RW Drive (E)
== DVD Drive (F:) =
*@ Colligo File Manager
» Colligo Intranet Copy SharePoint URL
4 Colligo Portal

Private Documents

Shared Documents

Site As
- Site Pa Open
¥ Disable Synchronization

Enable Synchronization

Filter Synchronization...

Default Metadata Values...

& Product Management
‘1‘! MNetwork
@ Control Panel

£ Recycle Bin <z

Site Assets

1 item selected

After you have enabled synchronization and set your filters, you need to start the synchronization
process. You can do this in one of two ways:

e Right-click the Contributor File Manager icon in the system tray and choose Synchronize All:

Open Colligo Contributor

Synchronize All
View Synchronization Status

Cancel Synchronization

Exit

e From the Site menu in the Contributor File Manager Control Panel, choose one of the following
options:
o Synchronize Multiple Sites: choose this option to synchronize more than one site. In the
Synchronize Multiple Sites dialog, check your preferred sites and click Synchronize.
o Synchronize All: choose this option to synchronize all sites
o Synchronize Pending Changes: choose this option to synchronize changes you have
made
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=
(@ Calligo Contributor File Manager

File St View Help

Synd i) Synchronize Multiple Sites. .

Tesu -_;-'J Synchronize All F9 Sl

—;J Synchrenize Pending Changes

Manage Sites...

List

Folder

| 3

@Nu Synchronization Activity

5. The Synchronization In Progress dialog displays for any of the above options:

Synchronization In Progress...

==

Site List:

& [ Coligo Intranet Server:
5 Contoso LLC

4 Matter Repository

Synchronization Activity

4 Product Management
Received: 0of0

Skip Site

Site: 4 Colligo Intranet
é:@ http:/fvs-sp2010

Current List: 23] Customized Reports
Status: Collecting remote updates ...

Sent: 0of 0

Weorking ...

Cancel All

[ Close this window when synchronization completes

Completing a Full Synchronization

Several of the synchronization dialogs have a Perform Full Synchronization option. This option means
that additional information is downloaded, including definitions for Sites, Lists, Views, and Content
Types, plus other site content that may not be retrieved during other standard sync processes.

12/02/2013
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Configuring Synchronization Settings

The synchronization settings for Contributor File Manager are set in the Options dialog.

1.

From the View menu, select Options.

The Colligo Contributor Options dialog displays:

l

Storage

Storage location

|C: Wsers\tmadkdnnon\AppData'Local\ColligoCr

General
¥ Prompt for properties when adding documents

™ Use current Windows(® appearance

Synchronization

v Synchronize on startup

¥ synchronize when list is viewed

¥ Synchronize when list is modified
¥ Enable background synchronization

Background synchronization interval: |30 minutes

v Automatically download lists to resolve Site Column values

0K ‘ Cancel |

Collige Contributor Options LﬁJ

L

4

Colligo Contributor File Manager

In the General section, you can turn on the prompt to record properties about the document by
checking the Prompt for properties when adding documents box. You can override this setting for
specific lists/libraries when you are configuring Default Metadata; see Setting Default Metadata.

In the Synchronization section, choose your preferred options:

a. Synchronize on startup: choose this option if you want your lists and libraries to synchronize

every time File Manager starts

b. Synchronize when list is viewed: choose this option if you want your lists and libraries to

synchronize every time a list or library is viewed

c. Synchronize when list is modified: choose this option if you want your lists and libraries to

synchronize every time a list or library is modified

d. Enable background synchronization: choose this option if you want to set the
synchronization to happen in the background on a time-specific basis, and enter your

preferred time interval

e. Automatically download lists to resolve Site Column values: if you have lists that reference
other lists (look-ups), checking this option ensures the related referenced lists are also

downloaded

12/02/2013

Copyright 2013 Colligo Networks, Inc. All rights reserved.

NOTE: Depending on how your IT Administrator has configured the File Manager installation, this dialog
may not be accessible to you, or the synchronization options may be greyed out.
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Creating New Content

After you have added your sites and synchronized your lists and libraries, the content is cached
(available offline). You can now open and edit SharePoint items, check items in and out of SharePoint, as
well as rename and delete items.

You can add items to Contributor File Manager in one of the following ways:
e Add a new document from within the Contributor File Manager interface
e Upload existing content

e Drag-and-drop or copy-and-paste content

e Use the File > Save As command

Adding a New Document to a List/Library

From within Windows Explorer, you can create and add a new document to a SharePoint location:

1. From the File menu, choose New > New Document:

. Sieeea)
@-u-v| <« Product Management » Shared Documents » - | +3 | Search Shared Documents o
PG cit view Tools Help
New 3 MNew Document B- ~ [ liéjn
Upload Documents Mew Folder it

Administrator
Create shortcut

m

Delete

Rename Briefcase Competitive Analysis
Properties
Close Contributor Dashboards

4 —olligo Portal

5 Product Management
€ Network Deployment Email Manager

[E3 Control Panel il

22 items
L

L5

NOTE: if you cannot see the File menu, press the Alt key to display it.
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The Create New Document dialog displays:

-

_] Create New Document lé]

Site Templates | Qther

@_j

template

Please enter a name for this new document:

Mew Document

[ Create ] [ Cancel ]

L5

Colligo Contributor File Manager

Choose your document type from the Site Templates tab or the Other tab.
Enter a name for the document, and click Create.
The New Item dialog displays.

-

3] Shared Documents: New Item

S

Document

L

@ j Mew Document. docx

Folder

A/ | [ Browse... ]
Properties

Name *

Mew Document. docx

Title

template.dotx

Description

-
[ Create ] [ Cancel ]

A

This dialog is where you can record information about the document. Edit as preferred.

Click Close. The document is added to the SharePoint location.
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Using the Upload Documents Dialog

From within Windows Explorer, you can upload existing documents to your preferred SharePoint
location:
1. From the File menu, choose Upload Documents:

= [ B [ |

@-u-vl <« Colligo File Manager » Colligo Portal » Shared Documents » - | &,| | Search Shared Documents o
_ Edit View Tools Help

MNew 3 B 0 @

Upload Decuments i it

Briefings copytest

Create shortcut g Pyt

Delete E

Rename SPC 2011 Presentations

Properties

Close LS Excel file.xlsx
s Colligo Portal =

. Product Management
t'-:‘I_-I Metwork
3 Control Panel IR IR

m

16 items
[

L

NOTE: if you cannot see the File menu, press the Alt key to display it.

The Upload Documents dialog displays.

2. Browse to the document that you want to upload, and click Open. To select more than one
document, use Ctrl + click.

3. The New Item dialog displays. Edit as preferred and click Create.
The document is added to the SharePoint location. If you have selected more than one document,
any properties you assign apply to all items.

Dragging-and-Dropping Content

You can drag-and-drop one or more files or complete folder structures into File Manager from your
desktop or from other directory locations:

1. Drag-and-drop your preferred files or folders from your desktop or another directory to your
preferred SharePoint location in Contributor File Manager.

2. The Edit Properties dialog displays. Edit as preferred and click Create.
The file or folder is added to the SharePoint location. If you have selected more than one document
or a folder, any properties you assign apply to all items.
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Using the File Save As Command
You can use the File > Save As command from integrated programs to save directly into any of the
SharePoint lists or libraries you have connected to Contributor File Manager:

1. Inyour open document, select File > Save As.
2. Inthe Save As dialog, navigate to your SharePoint location, edit the file name as needed, and click

Open:
@ Save As @

@-v-vl s ¥ Computer » Colligo File Manager » Colligo Portal » v“fll Search Colligo Portal 2

Organize = g - ':Q'
[/ Pictures ‘o
E Videos 1 Shared Documents
L
1% Computer
£, Local Disk (C:)
—u DATA(D:)
2 DVD RW Drive (E) 2
<45 DVD Drive (F:)
'@ Colligo File Manager
& Celligo Intranet
5 Colligo Portal

& Product Management

File name: -
Save as type: [Word Document (*.docx) -
Authors: Dave MacKay Tags: Add atag Title: Add a title
[ Save Thumbnail
= Hide Folders Tools = [ Save ] [ Cancel

3. The Edit Properties dialog displays. Edit as preferred and click Close.
The document is added to the SharePoint location.
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Setting Default Metadata

If you want to tag all documents and items that you add or upload to a list or library with the same
metadata, you can set default metadata values through the Contributor File Manager interface:

1. From the Control Panel File menu, choose Default Metadata Values.
The Default Metadata Values dialog displays:

Default Metadata Values &J

|contosa LLC ~|

Mame Value Inherited From Apply To

_.1 Content and Structure Reports
23] Customized Reports
L)
\z3] Drop Off Library
53] Form Templates
3] Images

1l Reusable Content
3] Site Collection Documents
|3 Site Collection Images
23] Style Library

2] Workflow Tasks

Add... When adding documents, prompt for properties:
i Always
[™ Inherit propagating values from parent items " Never
[~ Clear locally-defined values on all child items {* According to application global settings

Ok | Cancel Apply

2. Select the site and library/list that you want to configure.

3. To add a metadata tag, click Add.
The Add Default Meta data Properties dialog displays, displaying the metadata field options that
are set in the document library in SharePoint.

Add Default Metadata Properties &J

Title

™|

Scheduling Start Date
™ |

Scheduling End Date
|

'— Hropagate ese geTault metadats values o
e hfrldare

4. Enter your preferred tags and click Add.

5. If you want the values to propagate to any subfolders, check the Propagate these default metadata
values to subfolders box.

6. To configure the metadata prompt behavior, choose a radio button on the right under the When
adding documents, prompt for properties section:

e Always

e Never

e According to application global settings (as set in step 2 in Configuring Synchronization
Settings)
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