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Introduction 
Welcome to Colligo Contributor File Manager, the program that helps increase SharePoint adoption by 
seamlessly linking your SharePoint document libraries to the familiar Windows Explorer interface. Local 
folders become “SharePoint aware,” providing easy access to SharePoint features such as metadata, 
content types, and document templates. Folders can also be easily accessed from any application that 
uses the standard Windows File Open/Save dialog. SharePoint files can be added and edited using 
familiar desktop operations. 

Benefits 
Colligo Contributor File Manager helps: 

 Empower users to easily manage email and documents in SharePoint 

 Increase the quantity of content captured and tagged in SharePoint 

 Make SharePoint accessible directly from the desktop 

 Drive mobile and remote workforce productivity with easy offline access 

 Improve collaboration, and document project management 

 Improve records retention to reduce risk and improve compliance 

Features 
Colligo Contributor File Manager lets you: 

 Drag-and-drop documents to SharePoint 

 Navigate to cached SharePoint content 

 Sync documents, document sets, libraries, or entire SharePoint sites 

 Open, save, organize, and classify SharePoint files directly from Windows Explorer 

Platforms Supported 
 Microsoft SharePoint Server 2010, MOSS 2007, SharePoint Portal Server (SPS) 2003 

 SharePoint Foundation Microsoft Windows SharePoint Services (WSS) 3.0, or 2.0 

 SharePoint 2010 Online (Office365) 

 SharePoint 2013 Preview 

 Outlook 2007, 2010, 2013 Preview (32-bit and 64-bit) 

 Windows XP Professional, Windows Vista, Windows 7, Windows 8 
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Installing and Activating Contributor File Manager 
To install and activate Contributor File Manager: 
1. Double-click to open the zip file and extract the contents.  
2. In the folder, double-click the folder that corresponds to your operating system:  

a) x64: choose this option if you have a 64-bit operating system 
b) x86: choose this option if you have a 32-bit operating system 

3. Double-click either Setup.exe or .msi.  
4. Follow the steps in the install wizard.  
5. After the install is complete, the following dialog displays:  

 

6. Enter your information and click Activate.  
After Contributor File Manager is installed, a new group called Colligo File Manager displays as a 
location in Windows Explorer:  

 

NOTE: If the Colligo File Manager icon is not visible in Windows Explorer after installation, you may need 
to configure your options. See the following Knowledge Base article for instructions: 
http://www.colligo.com/support/kb/file-manager-icon-not-visible-in-windows-explorer/ 

  

http://www.colligo.com/support/kb/file-manager-icon-not-visible-in-windows-explorer/
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Activating Contributor File Manager Manually  
If you are unable to connect to the activation server, the following error message displays:  

 

Click Activate via Email to create an activation request file. The following dialog displays: 

 

Click Export Activation Request. This creates a .txt file that you can save anywhere on your machine, 
and then attach to an email that you can send to Colligo to request a manual activation.  

 Using the Contributor File Manager Control Panel 
The other part of Contributor File Manager is the Control Panel. This is a separate interface that displays 
in its own window. From here you can locate and configure options and see any sync issues such as 
conflicts or files being locked. 
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To display the Control Panel, open Colligo Contributor from your Start menu or from the system tray 
icon: 

 

Checking for Updates 
In the Contributor File Manager Control Panel, you can check if you are using the most current version of 
the program: 
1. From the Help menu, select Check for Update. The www.colligo.com site launches. 
2. If there is a newer version available, click the Download the latest version now link to install the 

newer build.  

Updating Your License Key 
In the Contributor File Manager Control Panel, you can change your license key: 
1. From the Help menu, select Install License Key.  
2. The Enter License Key dialog displays. Enter your new license key and click OK.  

 

  

http://www.colligo.com/
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Connecting SharePoint Sites 
You can add a SharePoint list or library to Contributor File Manager in one of two ways: 
 Using the Connect to Contributor option in Internet Explorer  
 Using the Download New Site option 

Using the Connect to Contributor Button 
1. Navigate to a SharePoint List or Library in Internet Explorer. 
2. Click the green Connect to Contributor icon on the toolbar. 

 

3. The Download New Site dialog displays. Select either your default Windows credentials, or supply 
other user-specific credentials. 

 

4. Click Download. 
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The Select for Synchronization dialog displays the lists and libraries you have permissions for: 

 

5. Check the boxes beside the lists and libraries you want to synchronize; use the Check All or Uncheck 
All buttons if needed. 

6. Click Filter to select which folders and views you want to synchronize. 
The Select Filters for Synchronization dialog displays: 
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7. Choose from the following options: 

 Disable Synchronization for this Document Library: choose this option if you do not want 
the document library to be available offline.  

 Synchronize Entire Document Library: choose this option if want to synchronize everything 
in the specified document library.  

 Only synchronize content based on the following filters: choose this option if you want to 
selectively choose what folders and views are synchronized. In the Synchronized Folders 
and Synchronized Views sections, select a folder or view you want to synchronize and click 
Add to move it to the Selected Folders/Views column. 

8. Click OK.  
9. Click Synchronize. The site displays under the Colligo File Manager group in Windows Explorer.  

Using the Download New Site Dialog 
To connect a site from the Windows Explorer interface:  
1. Right-click the Colligo File Manager node and select Download New Site from the contextual menu.  

 

The Download New Site dialog displays: 

 

2. Enter the URL of the site and use your default credentials, or user-specific credentials.  
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3. Click Download.  
The site displays under the Colligo File Manager node in Windows Explorer. However, the site’s lists 
and libraries are not synchronized at this point and display as greyed out in Windows Explorer.  

4. To synchronize a list or library, right-click it and select Enable Synchronization. To select filters for 
synchronization, right-click a list or library and select Filter Synchronization.  

 

After you have enabled synchronization and set your filters, you need to start the synchronization 
process. You can do this in one of two ways:  

 Right-click the Contributor File Manager icon in the system tray and choose Synchronize All: 

 

 From the Site menu in the Contributor File Manager Control Panel, choose one of the following 
options: 

o Synchronize Multiple Sites: choose this option to synchronize more than one site. In the 
Synchronize Multiple Sites dialog, check your preferred sites and click Synchronize. 

o Synchronize All: choose this option to synchronize all sites 
o Synchronize Pending Changes: choose this option to synchronize changes you have 

made 
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5. The Synchronization In Progress dialog displays for any of the above options: 

 

Completing a Full Synchronization 
Several of the synchronization dialogs have a Perform Full Synchronization option. This option means 
that additional information is downloaded, including definitions for Sites, Lists, Views, and Content 
Types, plus other site content that may not be retrieved during other standard sync processes. 
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Configuring Synchronization Settings 
The synchronization settings for Contributor File Manager are set in the Control Panel.  
1. From the View menu, select Options.  

The Colligo Contributor Options dialog displays: 

 

2. In the General section, you can turn on the prompt to record properties about the document by 
checking the Prompt for properties when adding documents box. You can override this setting for 
specific lists/libraries when you are configuring Default Metadata; see Setting Default Metadata. 

3. In the Synchronization section, choose your preferred options: 
a. Synchronize on startup: choose this option if you want your lists and libraries to synchronize 

every time File Manager starts  
b. Synchronize when list is viewed: choose this option if you want your lists and libraries to 

synchronize every time a list or library is viewed 
c. Synchronize when list is modified: choose this option if you want your lists and libraries to 

synchronize every time a list or library is modified 
d. Enable background synchronization: choose this option if you want to set the 

synchronization to happen in the background on a time-specific basis, and enter your 
preferred time interval 

e. Automatically download lists to resolve Site Column values: if you have lists that reference 
other lists (look-ups), checking this option ensures the related referenced lists are also 
downloaded 

NOTE: Depending on how your IT Administrator has configured the File Manager installation, this dialog 
may not be accessible to you, or the synchronization options may be greyed out. 
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Creating New Content 
After you have added your sites and synchronized your lists and libraries, the content is cached 
(available offline). You can now open and edit SharePoint items, check items in and out of SharePoint, as 
well as rename and delete items. 

You can add items to Contributor File Manager in one of the following ways: 

 Add a new document from within the Contributor File Manager interface 

 Upload existing content 

 Drag-and-drop or copy-and-paste content 

 Use the File > Save As command 

Adding a New Document to a List/Library 
From within Windows Explorer, you can create and add a new document to a SharePoint location: 

1. From the File menu, choose New > New Document: 

 

NOTE: if you cannot see the File menu, press the Alt key to display it.  
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The Create New Document dialog displays: 

 

2. Choose your document type from the Site Templates tab or the Other tab. 
3. Enter a name for the document, and click Create.  

The New Item dialog displays.  

 

4. This dialog is where you can record information about the document. Edit as preferred. 
5. Click Close. The document is added to the SharePoint location. 
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Using the Upload Documents Dialog 
From within Windows Explorer, you can upload existing documents to your preferred SharePoint 
location: 
1. From the File menu, choose Upload Documents:  

 

NOTE: if you cannot see the File menu, press the Alt key to display it.  

The Upload Documents dialog displays.  
2. Browse to the document that you want to upload, and click Open. To select more than one 

document, use Ctrl + click.  
3. The New Item dialog displays. Edit as preferred and click Create.  

The document is added to the SharePoint location. If you have selected more than one document, 
any properties you assign apply to all items.  

Dragging-and-Dropping Content 
You can drag-and-drop one or more files or complete folder structures into File Manager from your 
desktop or from other directory locations: 

1. Drag-and-drop your preferred files or folders from your desktop or another directory to your 
preferred SharePoint location in Contributor File Manager.  

2. The Edit Properties dialog displays. Edit as preferred and click Create. 
The file or folder is added to the SharePoint location. If you have selected more than one document 
or a folder, any properties you assign apply to all items.  
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Using the File Save As Command 
You can use the File > Save As command from integrated programs to save directly into any of the 
SharePoint lists or libraries you have connected to Contributor File Manager: 
1. In your open document, select File > Save As. 
2. In the Save As dialog, navigate to your SharePoint location, edit the file name as needed, and click 

Open: 

 

3. The Edit Properties dialog displays. Edit as preferred and click Close.  
The document is added to the SharePoint location.  
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Setting Default Metadata 
If you want to tag all documents and items that you add or upload to a list or library with the same 
metadata, you can set default metadata values through the Contributor File Manager interface: 

1. From the Control Panel File menu, choose Default Metadata Values.  
The Default Metadata Values dialog displays:  

 

2. Select the site and library/list that you want to configure.  
3. To add a metadata tag, click Add.  

The Add Default Meta data Properties dialog displays, displaying the metadata field options that 
are set in the document library in SharePoint.  

 

4. Enter your preferred tags and click Add.  
5. If you want the values to propagate to any subfolders, check the Propagate these default metadata 

values to subfolders box.  
6. To configure the metadata prompt behavior, choose a radio button on the right under the When 

adding documents, prompt for properties section: 

 Always 

 Never 

 According to application global settings (as set in step 2 in Configuring Synchronization 
Settings) 


